Re: [Gimp-developer] Problem with GIMP 2.9.x build dependencies

Carol, Partha,

thanks for your help. I am already using PyGTK-2.24.0, however it searches for pygobject-2.0.pc in the 
PKG_CONFIG path, and that’s what forces me to use a version of pygobject not newer than 2.28.6…

Partha, could you tell me which combination of library versions are you using for your windows and OS X 


On 18 May 2017, at 16:50, Partha Bagchi <partha1b gmail com> wrote:

On Thu, May 18, 2017 at 8:49 AM, Carmelo DrRaw <aferrero1975 gmail com <mailto:aferrero1975 gmail com>> 
Dear GIMP experts,

I am having troubles to compile the dependencies required to build the latest GEGL/GIMP versions from GIT.

The problem I am facing is the following:

* on one hand, GEGL requires GLIB > 2.44.0

* on the other hand, PyGTK (needed to have python support in GIMP) wants pygobject-2.0, whose latest 
version I could find is 2.28.6
However, this version must be compiled against a gobject-introspection version prior to this commit: 
<>> (Deprecate ErrorDomain), 
otherwise one gets compilation errors due to undefined enum values. So this brings me to 1.29.16 as the 
latest usable gobject-introspection version (at least according to release dates, see 
However, gobject-introspection-1.29.16 cannot be compiled against glib-2.44.0 because of g_module_* 
functions having been moved into a sport library, which gobject-introspection-1.29.16 is not linking…

Am I doing something wrong? Is there a recommended set of library versions for compiling GIMP? Or should I 
patch object-introspection to add the missing glib library?

Thanks a lot in advance!

Use pygtk-2.24 and you should be fine. 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]