[Gimp-developer] opencl error - gegl won't build without hard-resetting to an earlier version

I did "git pull" for gegl, tried to build, and got this error:

Making all in opencl
make[2]: Entering directory `/home/elle/code/gimp291/build/gegl/opencl'
/usr/bin/python ./cltostring.py bilateral-filter-fast.cl
Traceback (most recent call last):
  File "./cltostring.py", line 56, in <module>
    line = escape_string(line)
  File "./cltostring.py", line 31, in escape_string
    if isinstance(s, unicode):
NameError: global name 'unicode' is not defined
make[2]: *** [bilateral-filter-fast.cl.h] Error 1
make[2]: Leaving directory `/home/elle/code/gimp291/build/gegl/opencl'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/elle/code/gimp291/build/gegl'
make: *** [all] Error 2

So I hard-reset Gegl to October 24th,
commit 24580c4f4395be162a5e19b51681dd90d8639b59
and got the same error.

So I hard-reset Gegl all the way back to September 1, and Gegl built without any problem.

My computer doesn't play nice with opencl, if that is relevant. Is there a way to disable opencl before building?

Elle Stone
Articles on color management and open source photography

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]