[Gegl-developer] Gegl's configure does not detect well libpng and libjpg

Hello. I am currently trying to compile gegl 0.2.0.
To do so first I do export PKG_CONFIG_PATH=/media/34GB/Arquivos-de-Programas-Linux/gimp-2.0.0/build/lib/pkgconfig/ and then export LD_LIBRARY_PATH=/media/34GB/Arquivos-de-Programas-Linux/gimp-2.0.0/build/lib/. On these two directories, technically there is everything gegl would need.
On the lib dir there is: libjpeg.a, libjpeg.la, libjpeg.so, libjpeg.so.9.3.0, libpng16.a, libpng16.la, libpng16.so, libpng16.so.16, libpng16.so.16.37.0, libpng.a, libpng.la and libpng.so
On the lib/pkgconfig dir, there is  libjpeg.pc, libpng16.pc, libpng.pc.
And finally, on include, there is jconfig.h, jerror.h, jmorecfg.h, jpeglib.h, pngconf.h -> libpng16/pngconf.h, png.h -> libpng16/png.h, pnglibconf.h -> libpng16/pnglibconf.h, besides the dir libpng16 with the pngconf.h, png.h and pnglibconf.h inside of it
Yet when I run configure, I receive:
checking for jpeg_destroy_decompress in -ljpeg... no
checking for PNG... no
The png part I solved setting the PNG_CFLAGS and PNG_LIBS environment variables with: ./configure PNG_CFLAGS=/media/34GB/Arquivos-de-Programas-Linux/Png-1.0.19/include/ PNG_LIBS=/media/34GB/Arquivos-de-Programas-Linux/Png-1.0.19/lib/ (not the version I have on gimp-2.0.0/lib and gimp-2.0.0/lib/pkgconfig)
The jpeg part I solved with:
ln -s /media/34GB/Arquivos-de-Programas-Linux/Jpeg-6b/lib/libjpeg.a /usr/local/lib/ and with
ln -s /media/34GB/Arquivos-de-Programas-Linux/Jpeg-6b/include/j* /usr/local/include/ (that  created symbolic links to the aforementioned jconfig.h, jerror.h, jmorecfg.h, jpeglib.h, although the version inside gimp-2.0.0/build/include is from a different version, probably newer than this 6b version)
So I would like to know what I have to do to figure out why the configure did not detect the png and jpeg files inside, even though all required seems to be inside of the correct gimp-2.0.0/lib, gimp-2.0.0/lib/pkgconfig and gimp-2.0.0/include directories. And I know my two export PKG_CONFIG_PATH and export LD_LIBRARY_PATH commands did work, because there is a lot more files inside dir, all detect by the configure (like glib and babl stuff). Thanks in advance.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]