[gdm-list] [Solved] Re: gdm-simple-greeter...Error getting session id from systemd: No such file or directory

Ray Strode schreef op wo 20-03-2013 om 22:48 [-0400]:
On Mon, Mar 18, 2013 at 12:24 PM, tjoen <tjoen dds nl> wrote:
System: LFS-like
Migrating from upstart to systemd. After recompiling packages
for systemd-suuport everything works except gdm

gdm-3.6.2 built with:
./configure --prefix=/usr --disable-static \
 --with-sysconfsubdir=X11/gdm --with-dmconfdir=X11/dm \

Does adding --with-systemd explicitly help?

Thanks for your reply.
If systemd is found it gdm will be build with systemd.
Before recompiling (with systemd) gdm didn't have permission
to start, even by root.

In the meantime I found the solution (partial)

/etc/pam.d/system-auth contains:
session         required        pam_systemd.so

That is included by /etc/pam.d/gdm
But /etc/pam.d/gdm-launch-environment doesn't include
system-auth in it's session section. So I tried adding
that pam_systemd.so into gdm-launch-environment.
That works on one system using xorg's nv_drv.so.

But on the system with an Intel-videocard the first step
of gdm (the gnome-shell) results in an Oops-screen.
I can remember dat gdm-gnome-shell only had been
working in Gnome-3.0. I stopped working since 3.2, always
only starting fall-back mode.
I am almost certain that I can get gdm working there by 
uninstalling gnome-shell.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]