[gdm-list] gdm error message, all little squares

	Hello list,

I've been waiting for a few days to see whether this question is
correctly addressed to this mailing list, but didn't see any traffic, so
I'll give it a shot.
I have the following problem: since an update to my debian box (etch)
about two weeks ago, gdm is somehow broken. All I get is an error dialog
with an OK button, but I can't read the error message (or the button) as
the font is all little squares. When I press the button, gdm exits. The
logfile does not show anything interesting - one problem with the fglrx
driver (which isn't the reason because the xorg's standard ati driver
doesn't change anything), and some font-path-not-found problems (which
aren't the reason either, because after removing the offending font
paths from my xorg.conf, gdm does still not work).

I tried reconfiguring anything, I played around with the locale
settings, made sure xfs is working properly, I installed more fonts, and
searched google - but nothing helped so far.

The machine is running gdm version 2.16.1-1, xserver-xorg version is
1:7.1.0-5, xfs version is 1:1.0.1-5, the locale I use is en_US, gdm's
log output is appended below.

So I turn to this list for help, because I've run out of ideas where to
look next...
Any help will be appreciated!


_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/danielnb:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.15-gentoo-r5 i686 
Current Operating System: Linux danielnb 2.6.15-gentoo-r5 #1 SMP Mon Sep 25 22:03:30 UTC 2006 i686
Build Date: 15 October 2006
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov  5 23:13:56 2006
(==) Using config file: "/etc/X11/xorg.conf"
FATAL: Module mach64 not found.
[drm] failed to load kernel module "mach64"
(EE) ATI(0): [dri] DRIScreenInit Failed
(EE) AIGLX: Screen 0 is not DRI capable
    xkb_keycodes             { include "xfree86+aliases(qwerty)" };
    xkb_types                { include "complete" };
    xkb_compatibility        { include "complete" };
    xkb_symbols              { include "pc(pc105)+de-latin1-nodeadkeys" };
    xkb_geometry             { include "pc(pc105)" };
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Can't find file "de-latin1-nodeadkeys" for symbols include
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server
Could not init font path element unix/:7100, removing from list!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]