Building firefox on debian sid

Hi list,

I ran into some problem while compiling firefox on debian sid when
building 2.21.9x.

error is:
g++ -I/home/garnome/garnome/include  -fno-rtti -fno-exceptions -Wall
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic
-I/home/garnome/garnome/include -L/home/garnome/garnome/lib -O2 -pipe
-fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O -fPIC -shared
-Wl,-z,defs -Wl,-h, -o
nsXPCOMObsolete.o nsRegistry.o    -Wl,--export-dynamic
-L/home/garnome/garnome/lib   -L../../../dist/bin -lxpcom -lxpcom_core
-L../../../dist/bin -L../../../dist/lib -lplds4 -lplc4 -lnspr4
-L/home/garnome/garnome/lib -lpthread -ldl -L../../../dist/lib
-lxpcom_compat  -Wl,--version-script
-Wl,-Bsymbolic -ldl -lm
nsXPCOMObsolete.o:( undefined reference to
`nsFileSpecImpl::Create(nsISupports*, nsID const&, void**)'
nsXPCOMObsolete.o:( undefined reference to
`nsDirectoryIteratorImpl::Create(nsISupports*, nsID const&, void**)'
/usr/bin/ld: hidden symbol
`nsFileSpecImpl::Create(nsISupports*, nsID const&, void**)' isn't
/usr/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld returned 1 exit status
make[4]: *** [] Error 1
make[4]: Leaving directory
make[3]: *** [libs] Error 2
make[3]: Leaving directory
make[2]: *** [tier_2] Error 2
make[2]: Leaving directory
make[1]: *** [default] Error 2

After some google-ing i found out about bug #377178 (in debian bts)
where it is said that there is a visibility problem with gcc-4.2.

The problem is solved by building firefox with
"VISIBILITY_FLAGS=-fvisibility=hidden" as environment variable, then
build and install process went fine when running:

make -C /home/garnome/src/garnome-2.21.92/bootstrap/firefox install

I don't know if it is debian or gcc-4.2 specific, maybe the problem
can be referenced in the faq.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]