beagle-0.[89].x does not run on a PPC

I have beagle-0.0.7 running on a PPC under YDL-4.0.1, a FC2 clone.

Beagle-0.8.1 and beagle-0.0.9 do *not* run on my system owing to a DBUS
connection issue:

         INFO: Starting Beagle Daemon (version 0.0.9)
        DEBUG: Command Line: /opt/garnome/lib/beagle/BeagleDaemon.exe
        --debug --fg
        DEBUG: Initializing D-BUS
        FATAL: Could not initialize Beagle's bus connection.
        FATAL: System.ArgumentNullException: Argument cannot be null.
        Parameter name: dest
        in (unmanaged) (wrapper managed-to-native)
        in <0x00090> (wrapper managed-to-native)
        in [0x00004]
        (at /home/cvs/1-mono/mcs/class/corlib/System.Runtime.InteropServices/Marshal.cs:96) System.Runtime.InteropServices.Marshal:Copy (int[],int,intptr,int)
        in <0x0014c> GLib.Marshaller:make_buf_32 (string[])
        in <0x00054> GLib.Marshaller:ArgvToArrayPtr (string[])
        in <0x000a4> Gtk.Application:do_init (string,string[]&,bool)
        in <0x00028> Gtk.Application:InitCheck (string,string[]&)
        in [0x00291]
        (at /usr/local/src/GNOME/garnome- Beagle.Daemon.BeagleDaemon:Main (string[])
        free(): invalid pointer 0x102db000!

In each case Beagle was built using:
* gcc-3.3.3

* garnome- environment

* mono-1.06 stack
There are problems with the mono-1.1.x stack for PPCs. Some of these
problems have recently been resolved in the current SVN version of the
source code.

* dbus-0.23.4

According to the Beagle project page, beagle-0.[89].x should build and
run with the mono-1.06 stack and dbus-0.23.4.



joseph_sacco [at] comcast [dot] net

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]