[Bug 142099] New: - Cannot compile ORBit2 on Solaris with Forte compiler

ORBit2 | IDL compiler | Ver: unspecified

           Summary: Cannot compile ORBit2 on Solaris with Forte compiler
           Product: ORBit2
           Version: unspecified
          Platform: Other
        OS/Version: Solaris
            Status: UNCONFIRMED
          Severity: major
          Priority: High
         Component: IDL compiler
        AssignedTo: orbit-maint bugzilla gnome org
        ReportedBy: vix vazka sk
                CC: garnome-list gnome org

I'm trying to compile ORBit2 on Solaris. I can compile it fine with GCC-3.3.2,
but this time I have to use Sun's compiler.

Compilation stops while making Garnome in ORBit2 package:

gmake[9]: Entering directory
(rm -f corba-defs.h corba-defs-stubs.c corba-defs-skels.c corba-defs-common.c
corba-defs-imodule.c corba-defs-skelimpl.c || true) > /dev/null
../../../src/idl-compiler/orbit-idl-2 -I../../../src/idl/CORBA_PIDL
-I../../../src/idl/CORBA -I../../../src/idl/interop --noskels --nodefskels
--nostubs --noidata --nocommon --showcpperrors --define=Object=OObject
--define=TypeCode=TTypeCode --deps ./.deps/corba-defs.idl.P
orbit-idl-2 2.10.1 compiling
  mode, show preprocessor errors, passes: headers skel_impl imodule
../../../src/orb/orb-core/corba-defs.idl:27: Error: syntax error, unexpected
** (process:10821): WARNING **: ../../../src/orb/orb-core/corba-defs.idl
compilation failed
gmake[9]: *** [corba-defs.h] Error 1
gmake[9]: Leaving directory

I've tried to upgrade ORBit2 to latest version (currently 2.10.1), but did not work

When I try to replace .../../../src/idl-compiler/orbit-idl-2 with
/usr/bin/orbit-idl-2 (Sun Gnome 2.0 version), it makes no warning. But I don't
want to mix versions, releases and/or distributions.


CC = cc
CFLAGS += -xO3 -xlinkopt=0 -xtarget=ultra2 -xvis=yes
CXXFLAGS is the same as CFLAGS

PATH contains /opt/SUNWspro/bin
GNU make 3.80 and other GNU utils are present and in path.

I have also tried:

CPP = /usr/lib/cpp
export CPP
CXXCPP = /usr/lib/cpp
export CXXCPP
export LC_ALL
export LANG

I'm almost sure, the compiler is causing this, as I can build whole GNOME with
GCC-3.3.2. I've searched Google and Bugzilla, but none of solutions have worked.

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]