Re: gconvert.c, iconv.h error, but libiconv has been removed.

On Sun, 2003-10-05 at 12:01, donald_j_axel wrote:
>    Hello - could you help me with getting garnome to build?
>    I would like to build with garnome but hasn't been able to
> eliminate the iconv.h error which has been mentioned a year ago
> on this list, and which was solved (by Jeff Waugh and others)
> for Olivier Guery.
>    They simply adviced him to remove libiconv and try again.
> I have tried the same thing, that is, to remove my self made
> libiconv*rpm which had iconv.h in /usr/local/include 
>    It said that gcc-3.3.1 depended on it (and abiword) which
> forced me to do rpm -e --nodeps libiconv. I also renamed
> glibc-2.1 iconv.h in /usr/include and in
> /usr/i386-glibc21-linux/include/iconv.h
>    So it seemed that garnome already installed iconv in 'my home'
> which is set to /j3/src/gnome - there was .../garnome/include/iconv
>    I removed all of .../garnome and make clean then started over
> but now I get an error of missing iconv.h, like this:
> =================================================================================
> /bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DG_LOG_DOMAIN=\"GLib\" -DG_ENABLE_DEBUG -DG_DISABLE_DEPRECATED -DGLIB_COMPILATION   -I/j3/src/gnome/garnome/include -I/usr/X11R6/include -pthread  -g -I/j3/src/gnome/garnome/include -I/usr/X11R6/include -L/j3/src/gnome/garnome/lib -L/usr/X11R6/lib -O2 -pipe -Wall -c gconvert.c
>  gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DG_LOG_DOMAIN=\"GLib\" -DG_ENABLE_DEBUG -DG_DISABLE_DEPRECATED -DGLIB_COMPILATION -I/j3/src/gnome/garnome/include -I/usr/X11R6/include -pthread -g -I/j3/src/gnome/garnome/include -I/usr/X11R6/include -L/j3/src/gnome/garnome/lib -L/usr/X11R6/lib -O2 -pipe -Wall -c gconvert.c  -fPIC -DPIC -o .libs/gconvert.o
> gconvert.c:25:19: iconv.h: No such file or directory
> gconvert.c:62: error: parse error before "iconv_t"
> =================================================================================
>    If I go #$# cd ../../bootstrap/libiconv && make install
> then I get back to the other error, (line 45-46-47)
> #if !defined(USE_LIBICONV_GNU) && defined (_LIBICONV_H)
> #error GNU libiconv not in use but included iconv.h is from libiconv
> #endif
> ================================================================================
> So I can deduce as much as this: The glib needs iconv but cannot find its own.
> Or some other error is bugging me.
> Actually I feel sorry for the internet when using make clean because it also
> takes all the (GPG verified) tarballs away. Well, it is not so important now,
> but make garchive did not save my downloaded packages and the doc apparently
> is for some well known distribution.
> So I do not know how to proceed. I have updated most packages on my system
> so that the original RH7.2 only has left glibc-2.1 behind (almost only).
> That is because I need security updates immediately, so I build openssh,
> apache and postgreSQL from source and checkinstall (works like a breeze).
> How can I modify the system so that garnome will install? Or should I build
> from the dependency sequence on site, and just install from source?
> Should I update glibc-2.1? Would that mean recompilation of file-utils etc.
> (which would be fine with me)?
> Thank you in advance for a comment or two

Did you rebuild glib completely after installing bootstrap/libiconv?

As for glibc... hasn't 2.2 been stable for a long time? I believe I use

If you want to use a garchive, remember to define the GARCHIVE variable
in Tarballs should then be copied to the directory
specified when you run make garchive.

It sounds to me like your system is very highly customized. It's rather
hard to make any guess at what could be wrong.


> /Donald Axel
> -- 
> donald_j_axel get2net dk -- Linux works for me.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]