Re: [evolution-patches] Proxy Login Patches
- From: Jeffrey Stedfast <fejj novell com>
- To: Not Zed <notzed ximian com>
- Cc: Evolution Patches <evolution-patches lists ximian com>, Shreyas <sshreyas novell com>, psankar novell com
- Subject: Re: [evolution-patches] Proxy Login Patches
- Date: Tue, 12 Jul 2005 10:40:57 -0400
instead of guint16 permissions;, perhaps 'mode' would be a better name
as it fits in with the unix mode convention (as well as being shorter to
type)?
Jeff
On Tue, 2005-07-12 at 09:36 +0800, Not Zed wrote:
> I suggest these are just general permission bits, not with PROXY in the
> name.
>
> On Fri, 2005-07-08 at 16:06 +0530, Shreyas wrote:
> > +/* a proxy store with mail read/write permissions*/
> > +#define CAMEL_PROXY_STORE_READ (1 << 13)
> > +#define CAMEL_PROXY_STORE_WRITE (1 << 14)
>
> Also, they can probably start at bit 0, because the other bits are in
> the 'flags' field, not the separate 'permissions' one, right?
>
> Also, in the XML for the account, i'd probbly do something like:
>
> <proxy uid="foo"/>
>
> rather than:
>
> <proxy>
> <parent-uid>foo</parent-uid>
> </proxy>
>
> The code is simpler, the xml is smaller and easier to read, etc. (not a
> major thing, but might be nice).
>
> The rest looks ok. thanks.
>
> Oh, account_can_send, leaks the store.
>
> Do something like:
>
> res = (store->permissions & CAMEL_STORE_WRITE) != 0;
> camel_object_unref(store);
>
> return res;
>
>
> It could probably also check the id->address is set too rather than
> having to check that manually everwhere you check if the account can
> send.
>
> Michael
>
>
>
> _______________________________________________
> evolution-patches mailing list
> evolution-patches lists ximian com
> http://lists.ximian.com/mailman/listinfo/evolution-patches
>
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]