Re: [Evolution] How often should I expect OAuth2 authentication to fail ?

On Mon, 2019-07-01 at 12:38 +0200, Milan Crha via evolution-list wrote:
On Thu, 2019-06-27 at 11:09 -0500, Japhering via evolution-list

Then I installed the flatpak version.

I tried on a Fedora 30 machine, which runs GNOME, and installed
Evolution Flatpak version from Flathub. I configured a new account
there, instead of using any backup. I did not left checked to add
Calendars and Contacts for the Gmail account. I also opened Seahorse
and deleted the OAuth2 token from there (on the host machine). Then I
ran Evolution from Flatpak (it says in Help->About: 3.32.3 (flatpak
git)). I've been asked to login to the Google site to get the OAuth2
token. This worked flawlessly. I saw my mail messages from Gmail.
that I closed Evolution and ran it again (flatpak run
org.gnome.Evolution) and I've not been asked to re-renter my OAuth2
token, neither I saw any error in the GUI, the account successfully
connected to the server.

Shutdown Evolution.  Upon restart the flatpak version comes up and
pitches the following error.

   (evolution.bin:57): e-mail-engine-WARNING **: <time>: Failed to
   service 'Sendmail'(sendmail): No provider available for protocol

That's (more or less) correct, the Flatpak version doesn't have
to the host system sendmail, thus it is disabled in the code.

In the error window with in Evolution shows

   Data source “<email>” does not support OAuth 2.0 authentication

for each account trying to use OAuth2.

For each mail account, or others?

Both accounts are setup with 

   Receiving Email:
      Server:  Port:993
      Encryption method:  TLS on a dedicated port

I have the same.

   Sending Email:
      Server:  Port: 587
      Encryption method:  STARTLS after connecting

I use port 465 and "TLS on a dedicated port", which had been auto-
selected by the configuration lookup. This may not have any impact,
because it's used only when sending messages, not when receiving
The authentication type says "OAuth2 (Google)" for both parts of the
mail account. The "" in the addresses (for both IMAP and
can be changed to "" and it should work too.

I've tried both ports and both methods .. neither of which worked

Neither is successful at authenticating with the Gmail servers.

Works fine for me. I also tried with the added Calendar and Contacts
(at the end of the New Mail Wizard) and it works fine too.

I didn't have it running for several hours, of course, I simply tried
to close evolution and run it again, which I understood as being one
the ways to reproduce the error message for you.

This might be a stupid question, and I apologize for it: did you
install the Flatpak version from Flathub or from anywhere else? I did
use the Flathub version myself and I suppose you did too.

Yes, from flathub.

The main difference I can see, apart of using different distribution,
is that I configured the account from scratch, while you used some
backup. Could you try with a fresh account instead, please? I do not
see anything else different, especially when you use the same Flathub
version as I do.

Ok.. I'll scratch one machine and rebuild flatpak and NOT import data. 
It will be a day or two.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]