[Evolution] Fatal TLS Alert

I just upgraded to Ubuntu 18.10 (Pop_OS! 18.10) so I now have Evolution
version 3.30.1-1 build1

I am getting the following error when I try connecting to my IMAP work
email account:

The reported error was “Failed to get capabilities: Peer sent fatal
TLS alert: Illegal parameter”.

I tried changing between TLS and STARTTLS, and connecting via port 143
(this is the one suggested in the IMAP server setup page) and also 993

these settings worked before the upgrade to 18.10.   And still work on
the gmail client on my phone.

I tried setting up the same account on geary, and claws.  Geary didn't
get th email, but didn't provide any useful feedback.  Claws showed the
same error.

When I set up this account on Thunderbird, I got a messages about the
sites certificate being from an unrecognized source, and did I want to
grant an exception.   When I granted the exception, thunderbird
conencted to the server and got my mail.

So, I am going on the assumption that the TLS problems with Evolution
might be casued by the dodgy certificate my employers email provider is

I looked around a bit, but couldn't find any means to tell Evolution to
trust a particular certificate.  Is this possible?  Can you point me to
some instructions?



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]