[Evolution] Problems importing address books into Evolution 2.2.3 under FreeBSD 5.4-STABLE


I am having problems importing address books into Evolution 2.2.3 under FreeBSD 5.4-STABLE. I have tried two methods, and neither work.

Method #1: Importing a .ldif file

Using an .ldif file created by Mozilla Seamonkey under Windows XP, all fields import correctly except those for the home street address, home city, state and zip. The home telephone does import. I have also tried .ldif files created by both Mozilla Mail ad Thunderbird under FreeBSD and the same problem occurs.

Method #2. Converting a .csv file using the script csv2vcard.pl

Attempting to convert a both DOS and Windows .csv files created by Outlook under Windows XP using the script csv2vcard.pl fails with the following display

   [~/personal/aacn]$./csv2vcard.pl bod_mbr_dos.csv bod.vcf

   Takes a CSV-formatted list of contacts from Outlook and attempts to
   convert it into a list of VCards suitable for import into Evolution.

   Usage: ./csv2vcard.pl [infile outfile]


This script does create an empty file, bod.vcf, in the ~/personal/aacn directory.

I hate to sound hypercritical but the address books under Mozilla Mail and Thunderbird allow importing either comma-separated/tab-separated files using field mappings or .ldif files, and work without problems.

Why can't Evolution offer the same mechanism for importing .csv files?

BOF, FreeBSD User

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]