Re: [Evolution] Hang while formatting message

Try setting the environmental variable EVOLUTION_NO_BAR=1, and see if
that stop the hangs.

Also, try disabling 'load images if sender is in addressbook', it might
be the addressbook lookup hanging - which isn't cancellable either.

I guess, file a bug, include a backtrace of all threads, and preferrably
attach example messages.

On Thu, 2005-09-01 at 19:59 -0400, Patrick O'Callaghan wrote:
This is in 2.3.7 and 2.3.8 at least, maybe other versions as well.

Often, when some HTML-formatted message is in the preview pane, I see
the message text and graphic placeholders, the status message at the
bottom says "Formatting message (...)" and never terminates, i.e. the
preview pane is now stuck on the message that provoked the problem. Note
that Evo itself doesn't hang: I can double-click on other messages and
see them, change folders, set preferences, send and receive mail, etc.
etc., but I cannot change the contents of the preview pane again without
forceably killing Evo and restarting.

"Cancel" does nothing.

"Quit" causes the Evo window to grey out and sit there forever. (<rant>
A Quit button should quit the application *always* -- IMHO an end user
shouldn't have to know about "evolution --force-shutdown"; I actually
have a special "KillEvo" button on my desktop since I need it so often,
even with supposedly stable versions of Evo </rant>).

In Preferences I have "Show animated images" OFF, and "Load images in
mail from contacts" ON. I've played with various combinations of these
without affecting the frequency of this bug.


Evolution-list mailing list
Evolution-list gnome org
adfa(evolution-2.4:20087): gtkhtml-WARNING **: cannot find icon:
'stock_insert-url' in gnome 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]