[Evolution] Where did my imap "INBOX" go?

Hello all,

        Just read a message that an upcoming version of Evolution would finally
support in-line PGP.  Woo hoo!  Hooray!  One less thing I have to resort
to Mutt for (the next being piping messages to arbitrary commands and
scripts - any thoughts or comments?).  I'm also hoping to get Exchange
connector working again (it's been broken for me since 2.0.x for various
and varying reasons but that's another story for another message later).

        So, I checked the Fedora Core development repositories and, sure
enough, we've got 2.3.6 there waiting.  Cool...  I don't mind jumping
out on the bleeding edge occasionally and it seems to be a necessity, at
times, with Evolution.  I had to jump up to the development versions for
some "process terminated prematurely" problems (alarm, storage) that
seem to be solved there after I upgraded from Fedora Core 3 to Fedora
Core 4.

        So...  After upgrading and then after waiting several minutes for the
new version of Evolution to resync all my mailboxes and folders (6
active accounts, 4 of which are imap, with several hundred folders, some
of which are VERY large - seemed to take FOREVER) I seem to be back in
business again.  Almost...

        My old default system "Inbox" is missing from my two primary imap
accounts.  I had noticed this problem months ago under the 2.0.x
versions when I tried the imap4rev1 option for other reasons, which
immediately drove me to switch BACK to plain imap.  Now, under 2.3.6,
the same problem seems to be present in the plain imap.

        Seems like imap4rev1 is even more broken.  If I switch an account from
imap to imap4rev1 I get an immediate error from that account (for
example, my server "mtking.ip6.wittsend.com) saying "Unexpected token in
response from IMAP server mtking.ip6.wittsend.com: No data".

        Both accounts in question are "Dovecot" servers (one, mtking, is a
Fedora Core 3 system the other, chaos, is a Fedora Core 4 system) and
they are both accessed over SSL over IPv6.  Both worked with 2.2.3 with
the INBOX present, both were missing the INBOX when I tried 2.0.x with
imap4rev1, both are missing the INBOX on 2.3.6 with imap and both blow
an "Unexpected token in response" error with 2.3.6 and imap4rev1.

        A third account is on a cyrus imap server and that seems to still list
my "Inbox" under imap, but imap4rev1 still bombs with the "Expected
token" error.  That's also over SSL over IPv6 (if that really matters at

        A fourth account is my account on "samba.org" which, as a Samba Team
member, has to be accessed using imap over ssh in preauth mode using a
custom command.  THAT still shows my system inbox.  What ever it was
that has caused this doesn't seem to have broken that.  But that's the
imap server that comes with Debian.  Obviously, that's just plain imap
(no TLS/SSL) though it's tunneled over SSH and merely IPv4 to boot.
Interestingly enough, I can't use imap4rev1 with my Samba account
(tested just for completeness for this report), but for a totally
different reason.  If I select imap4rev1 as the protocol, I get prompted
for a password, even though the imap server would be operating in
preauth based on the ssh connection which was established by my ssh dsa
key.  I shouldn't get prompted for a password at all, but there it is.
Back to imap on that account to.

        Anybody have an idea wherefore disappeared the system INBOX for those
accounts on the Dovecot servers or why imap4rev1 appears so broken?  Any
idea how to turn my system mailboxes back on?

 Michael H. Warfield    |  (770) 985-6132   |  mhw WittsEnd com  
  /\/\|=mhw=|\/\/       |  (678) 463-0932   |  http://www.wittsend.com/mhw/
  NIC whois:  MHW9      |  An optimist believes we live in the best of all
 PGP Key: 0xDF1DD471    |  possible worlds.  A pessimist is sure of it!

Attachment: signature.asc
Description: This is a digitally signed message part

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]