Re: [Evolution] Backup and Restore

From: "D. D. Brierton" <darren dzr-web com>
To: "Celsun ." <tarcell hotmail com>
CC: evolution lists ximian com
Subject: Re: [Evolution] Backup and Restore
Date: Mon, 02 Feb 2004 19:01:03 +0000

On Mon, 2004-02-02 at 18:14, Celsun . wrote:
> Someone please point me in the right direction or post step-by-step
> instructions for backing up and restoring Evolution.
> Following some of the posts on this list I did the following on MDK 9.1 to
> backup Evo 1.4.5:
>    evolution --force-shutdown
>    pruned all indexing files mbox.* in ~/evolution/local/(sub) folders
>    In ~/evolution  tar czvf evolution.tar.gz evolution

This seems odd. Which directory were you in when you ran the command
"tar czvf evolution.tar.gz evolution"? Because from what you wrote above
it appears that you were in ~/evolution and not in ~. In which case you
have made a tarball of the contents of ~/evolution/evolution which is
not what you wanted.

Unforturnately, I was in ~/evolution instead of ~. Evidently, I didn't fully understand posts I was taking notes from.

This is what you should have done:

evolution --force-shutdown
cd ~
find evolution -name "mbox.*" -exec rm -f '{}' ';'
tar -cvzf evolution.tar.gz evolution

> this did create the archive and I moved it to a FAT partition on another
> hard drive
>    copied ~/.gconf/apps/evolution/ to another hard drive
> Restore to a fresh install of Evo 1.4.5, on a fresh install of MDK, before
> running it the first time
>    Moved     evolution.tar.gz into ~/evolution from the other hard drive

Again, this just looks odd. Let's say that you did do the first step
correctly and you do have a tarball of ~/evolution and NOT
~/evolution/evolution. If so, then you do NOT want to move evolution
into ~/evolution (if you hadn't run evolution before did you have to
create that directoty?)

No, the directory was already there.  Maybe I did run it... don't remember.

but instead move it into ~ (in other words its
full pathname should be /home/celsun/evolution.tar.gz.

>    tar xzvf evolution.tar.gz

That is the correct command to extract the tarball if it was created
from your home directory and if you are running it from your home

>    Nothing happened  after trying it a couple of times it created
> ~/evolution/~/evolution or         something like that

That's because it looks like you have manually created an evolution
directory, and then put the tarball in it and unpacked it there. The
good news is that it looks like you have created the tarball correctly
(so you haven't lost anything, unless you've deleted it now) but you are
just unpacking it in the wrong directory.

As stated above the ~/evolution directory was already there.

>    Copied ~/.gconf/apps/evolution/ back
> It turned out to be a big mess and even though I saw hundreds of files being > archived, the archive file appears to be empty now. (46B) How and why did
> this happen?

See above. Hopefully you created the tarball correctly and have just
been untarring it in the wrong place, so you haven't lost anything. Of
course if you created the tarball incorrectly in the first place too
then you are screwed.

> Unfortunately, evolution was not backed up so I've lost over a year's worth
> of e-mails.

But you still have the tarball don't you?


I think you can still recover your original mail. Do this:

evolution --force-shutdown
cd ~
mv evolution
tar -xvzf path/to/evolution.tar.gz

then run evolution. Hopefully all your old data will be back. Now the
only thing left is to import any new data from ~/ back
into Evolution using File -> Import.

Well, tried it and nothing happened. First, I copied the tar.gz into ~/ and that didn't work. Then, tried from the other drive where the tar.gz is.



Thank you Darren. Using what you've posted above for archiving and restoring, I will try that and then delete ~/evolution for a little practice.


Let the new MSN Premium Internet Software make the most of your high-speed experience.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]