Re: [Evolution] Filter Problems

I believe I've just fixed this problem in CVS so the next snapshot
should reflect this. If it doesn't, let me know.


On 22 Jul 2001 01:11:18 -0400, Sejal Patel wrote:
Hey Evolutionaries,
  I've noticed a problem in the filters lately and figured it was just a
specific snapshot bug until I saw it in the beta release I just
installed.  The problem is that if I have a filter setup to move a
message a folder like Foo and then tell it to stop processing then it
will move the file from any folder except the Foo folder to the Foo
folder.  If you are in the Foo folder and run the filter, it will simply
delete the message and do nothing else.  
  This becomes a really big problem if someone suddenly decides to make
a subfolder in Foo called Bar and then do a new filter criteria and then
goes through all the folders selecting all the messages and clicking on
the 'Apply Filters' option.  
  Logically you would expect it to simply go through and leave messages
alone if they are already in the appropriate location and move the
messages if they are not but instead it will move the messages if they
meet the new filters and get deleted if they were already in the correct

Sejal Patel (sejal iname com)

"I can call spirits from the vasty deep.  Why so can I, or so can any
but will they come when you do call for them?"
                                        Shakespeare, King Henry IV, Part

evolution maillist  -  evolution ximian com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]