Re: [Evolution] Evolution and debian

On Thu, Nov 09, 2000 at 04:32:20AM -0200, Bradley Shuttleworth wrote:
deb ./

after an apt-get update, all I get is this error message.

venice:/home/mattrose# apt-get install evolution
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

  evolution: Depends: libbonobo1 (< 0.24) but 0.26-0.2 is to be installed
             Depends: libgtkhtml5 (>= 0.7) but it is not going to be
             Depends: bonobo (< 0.24) but 0.26-0.2 is to be installed
E: Sorry, broken packages

The problem is that Debian has uploaded bonobo 0.26, but Evolution
currently still requires 0.23.  This is an evolution problem across the
board, and there were (possibly) plans a while back for an interim
release that fixes this dependency.  I'm not sure though ....  If you
aren't using nautilus, you can probably just grab the bonobo debs
manually, force their installation and then apt-get install evolution
should work like a charm.

This is confirmation for the lists's sake. If you install libbonobo1
and bonobo from the evolution apt source above, evolution will
work. There wasn't really any way I could get around this, save making
evolution depend on the exact version of bonobo needed. That at least
gives errors if you don't have the correct package installed.

I have those bonobo packages installed and put on hold.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]