[Evolution-hackers] Source-Upgrade to 1.2.(1) fails on gonme-vfs


I build my evoution(s) since pre1.0 on my own (it's been fun) and now tried to upgrade to 1.2.1. Lots of dependencies, but i compiled and installed:

g soup-0.7.10 --disable-gtk-doc
g gal-0.22
g gtkhtml-1.1.7
g oaf-0.6.10 -nocheck
g gdk-pixbuf-0.22.0
u linc-1.0.1 --disable-gtk-doc
u libIDL-0.8.0
u ORBit2-2.6.0
g GConf-2.2.0 --disable-gtk-doc
g bonobo-activation-2.2.0 --disable-gtk-doc -nocheck
g libbonobo-2.2.0 --disable-gtk-doc
g gnome-mime-data-2.0.1 --disable-gtk-doc
g gnome-vfs-2.2.0 -nocheck --disable-gtk-doc
g evolution-1.2.1 -nocheck --disable-more-warnings --with-db3=$LIBDB3
  --with-openldap=/usr/ldap --with-static-ldap=yes

(u means /usr, g means /opt/gnome, yes, gtk-doc is a bit broken now)

Unfortunately, ./configure for ev1.2.1 breaks and complains about missing gnome-vfs.

> configure: error:

> You need GNOME-VFS 1.0.5 or higher to build evolution
> If you think you already have this installed, consult the README.

My first version was gnome-vfs-1.0, indeed. I tried to upgrade to -1.9.17 first, which made no difference.

Then I desperately tried to downgrade 1.1 and 1.0.5. Unfortunately those VFS packages fail to compile due to some inconistencies in the gobject-stuff.

Unfortunately, now the editor component of evolution 1.0.8 fails to be activated, and I have no working evolution mail client at alll. What a pity.

Any idea how to bootstrap from that swamp?

- Marian

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]