Re: "Unrecognized image file format" error when loading JPG file

Hi Jens

I just noticed something when I opened "Open file..." dialogue. In "Determine File Type:" combo list I do not have JPG file format (my default option is "By Extension"). Could this have anything to do with this?

Also, I tried finding any 16 bit JPG files on the net to try and see if I can open them, but I could not find any (if you have one, could you please e-mail it to me).

In addition, I have submitted this to BUG#126672

Best regards


On Mon, 2003-11-10 at 18:44, Jens Finke wrote:
Hi Benjamin,

On Mon, 10 Nov 2003, Benjamin Kopic wrote:
> I am using Gnome 2.4 and keep getting the following error when trying to
> load any JPG file:
> Loading failed
> Loading of image BigBrother.jpg failed.
> Reason: Unrecognized image file format.
> However, I am able to load it using 'xloadimage' or analyse the files
> using 'jpeginfo' utility:
> benko smee benko $ jpeginfo download/BigBrother.jpg 
> download/BigBrother.jpg  600 x 554  24bit JFIF  N   97033 
> Also, I can convert the JPG file into PNG (using 'jpegtopnm' utility)
> and then open it without any problem in 'eog'.
> The problem is only with JPG (JPEG) files, and I have not noticed any
> issues with other file types. I tried running 'eog' in a verbose/debug
> mode but could not found an option for it.
> Annoyingly, this used to work (in my Gnome 2.2), which stopped working
> when I updated one of my applications (not sure which one). I suspect it
> has something to do with MIME types or something, but I cannot find out
> what. As a result the problem is in all Gnome applications that display
> JPG files (except mozilla and epiphany).

All Gnome programs use gdk-pixbuf as a graphic library for loading and
saving image files. Since this happens in all Gnome programs for you
(epiphany and mozilla both use other code for displaying images), it is
very likely a bug in this basic library (which comes with GTK).

Does it happen with all kind of jpeg files? This is a 24bit jpeg file, 
which may be the source of the problem. Anyway, could you attach a test 
file where it doesn't work to a bug in our bug tracking system at This would be very helpful. Thanks.

benjamin kopic
m: +44 (0)780 154 7643
t: +44 (0)20 7794 3090
e: benjamin kopic panContext com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]