Re: [Ekiga-list] Ekiga 4.0.1 and Renavisio

Hash: SHA256

Hi all,

Just to let you know we had our first real RENAVISIO conference with
Ekiga 4.0.1 today.

There were 8 participants (4 audio + 4 video), and everything worked
perfectly !

Many thanks to everyone involved in that great piece of software :)

Cheers, Samuel

Le 21/07/2015 15:18, Eugen Dedu a écrit :
Hi Samuel,

I propose you to compile opal 3.10.10 with libav version 8, or
with version 9 and the patch libav9 from,
or version 10 with patches libav9 and libav10.

(For your information, the unstable code should work without
patches with ffmpeg, but not with libav.  Hehe, there are several
if-s here, but hopefully in the near future everything will be
settled.  Debian has just switched from libav to ffmpeg.)


On 21/07/15 13:23, Samuel VISCAPI wrote:

Hi Eugen,

For now, as this is for production environment, I'd rather stay
on the stable 4.0.1 version. But if time permits, I'd be glad to
test the unstable branch and report here though :)

On a side note, I didn't managed to compile Opal 3.10.10 with
either libav 11.4/10.7 or ffmpeg 2.7.2. I tried to apply the
Debian patches you told me about, but the patch command failed on
some chunks. I tried to add these by hand, but that only led to
more errors... Could you help me on this one please ?

In the mean time, we received the new x86 based machine, an Intel
NUC D34010WYKH, which is of course a lot more powerful than the
tiny Raspberry Pi 2.

Cheers, Samuel

Le 16/07/2015 16:03, Eugen Dedu a écrit :
Samuel, would it be possible to you to use ekiga unstable code 
instead of ekiga 4.0.1?  We are fixing bugs for the former,
while the latter is too old to fix bugs.  Note that for the
moment you need to use ffmpeg, not libav, for the unstable code
of ekiga.

On 16/07/15 15:52, Samuel VISCAPI wrote: Hi Eugen,

Thanks for your offer, but I won't have too much free time
today for testing, sorry. I could be more available tomorrow
morning, I'll let you know.

I found something quite interesting: even though the Raspberry
Pi 2 supports the NEON set of instructions, I couldn't get 
libav-0.8.17 to compile with NEON enabled.

I just checked with libav-11.4, and the configure script seems
to like NEON better :) Using these instructions could lead to
a significant performance boost on ARM platform, and maybe make
Ekiga usable on the Raspberry Pi 2. I'll give this a try ASAP

Ultimately, If that doesn't work, we'll have to use a beefier,
x86 based machine (which is already ordered).

Cheers, Samuel

Le 15/07/2015 20:00, Eugen Dedu a écrit :
Hi Samuel,

We can make some tests tomorrow if you wish, I have
access to renavisio too.  Note that I will use the
development code in order to allow to fix any issue which
might appear.


On 08/07/15 17:53, Samuel VISCAPI wrote:

Hi all,

I managed to compile Ekiga 4.0.1 with H.263 support,
with libav-0.8.17 :) With this build I could join a
Renavisio conference and have a short, rather sluggish
(~15 FPS + stuttering sound) talk with my
colleague...before the Raspberry PI 2 crashed ;)

I'll try again later with some overclock and / or more 
memory dedicated to the GPU.

Stay tuned !

Cheers, Samuel

Le 08/07/2015 12:54, Samuel VISCAPI a écrit :
Hi all,

Thanks for your answers, I'll try to build Ekiga
with H.263 support ASAP. By the way, is there a
recommended version of libav for that purpose ?

@ Eugen: I built Opal 3.10.10 from sources, do I
still need to apply those Debian patches (on
Raspbian/ARM) ?

Cheers, Samuel

Le 07/07/2015 17:15, Eugen Dedu a écrit :
On 07/07/15 16:38, Samuel VISCAPI wrote:

Dear all,

This is my first post to that mailing list :)

I'd like to use Ekiga to participate in a
conference hosted on Renavisio, the French
education visioconferencing platform:

I managed to join the conference room using the
SIP protocol. I had to set DTMF mode to RFC 2833
in order to type in the password though.

Audio is working correctly, but video is not. I
can't see my colleague (in CC) who's connected to
the same conference room, and he doesn't see me
either. The webcam is a Logitech C920, which
appears to be working just fine in the "echo
test" room. As for my colleague, he is using
Scopia and the H.323 protocol:






By the way, I'm running Ekiga 4.0.1 compiled
from sources on a Raspberry PI 2. I followed
these instructions:

What am I doing wrong ?

P.S: Damien told me it could be a video codec
issue. So far, only theora and h261 are available
in the "Preferences" menu. If need be, I could
install libav/ffmpeg and libx264 then recompile

Hi Samuel,

I would relaly love to make Ekiga work with
Renavisio. I plan to test it myself, but I am
pretty busy at the moment.

I see at that
the H263 codecs are needed.  You need libav 
(perhaps ffmpeg works too) for that. There is a
patch (or two) you need to use, see


_______________________________________________ ekiga-list mailing
list ekiga-list gnome org

Version: GnuPG v2.0.17 (GNU/Linux)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]