Re: [Ekiga-list] How can I get non-free video codecs. ekiga 3.2.7 ubuntu 10.10

Le 09/01/2011 17:00, Eugen Dedu a écrit :
> On 09/01/11 01:22, Gérard Vidal wrote:
>> Hello,
>> I have to communicate through H323 with h263-1998 codec ( to join a
>> meeting on a codian bridge).
>> I have installed ekiga 3.2.7 on my ubuntu maverick (Dell precision
>> M2400), it works fine but displays only codec H261 and Theora. I have
>> read informations on this page
>> but it
>> seems to be outdated.
>> I have tried many things including full rebuild of latest version but
>> nothing works.
>> Does anybody have a solution or any track to follow.
> Your case is not simple.  First, because there are some bug reports
> about H323 not working in ekiga in some cases, see bugzilla.
> Also, because for these non-free codecs you need tom compile ffmpeg
> yourself, because distributions strip them out.
> Finally, because h263-1998 crashes when using ffmpeg last version, see
> bugzilla again (bug for H263); however, if you choose a repository for
> ffmpeg of about 1.5 years ago, it should work, see the same bug report.
> Are you motivated to test it?
Thank-you Eugen for the answer and the understanding of my situation !
As you describe it, I have experienced H323 unstability, it worked well 
few hours ago from home (with ekiga 3.3.0 and ffmpeg 0.6.1) and now it
freezes after the first ring then hangs up and returns to local
situation, when I try to place an h323 call from my office.

I have made many compilation tests with various versions of ekiga and
various versions of ffmpeg a few more will not be a problem ;-) .

I am motivated but I need guidance :
As I have pulse installed with my Maverick I suppose that I need to
choose at least 3.3.0 version or git. Am I right and in that case which
one will be the best?
I am now used to compile ffmpeg but I have noticed problems with the
companion libraries of the "libav* family" to avoid them I try to drop
the results in /usr/local tree but that may not be convenient  to
achieve what you are proposing. Let me know what to do and which version
of ffmpeg to use.

Finally to finish up the complexity frame I am using ffmpeg to encode in
mp4  our conferences and I need libx264. I noticed that h264 was always
excluded by ekiga and I have seen that in the log  it "failed to load
x264_encoder_open"  that may be due to the fact that from what I have
seen the x264 encoder carries now its version number for exemple
x264_encoder_open_112 for the last version. This might be modified in Ekiga.

PS can you give please adresses in bugzilla.
Thanks again


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]