Re: [Ekiga-list] ANNOUNCE - Ekiga 3.2.5 [STABLE] available

On Tue, Jul  7, 2009 at 21:31 (+0200), Eugen Dedu wrote:

Thanks for the quick response.

> Jim Diamond wrote:

>> I tried compiling this on Knoppix 6.0.1

>> In the end I could not convince Knoppix, apt-get and ekiga's configure
>> script to see eye-to-eye regarding dbus, and had to configure it with
>> 	--disable-dbus

> The main error is here.  What is the error with dbus enabled?

Here is the end of the output from configure:

checking for XV... yes
checking for DBUS... configure: error: Package requirements (dbus-1 >= 0.36 dbus-glib-1 >= 0.36) were not met:

No package 'dbus-1' found
No package 'dbus-glib-1' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DBUS_CFLAGS
and DBUS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

OK, I'll just try installing dubs-1:

sudo apt-get install dbus-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package dbus-1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
E: Package dbus-1 has no installation candidate

It may well just be that I am not debian-compliant, but I don't know
what to install, and a (quick) web search did not help me on this one.

If someone can tell me how to make configure happy, I'd be even
happier.  Or tell me which packages to install...

I tried fooling configure by saying
env DBUS_LIB=" " DBUS_CFLAGS=" " ./configure ...
but some compile or link eventually crashed and burned.

>> Problem 1
>> ---------
>> Unfortunately, it is unable to see any audio or video devices this
>> way.  Does it use dbus to figure out the a/v devices, or do the
>> assembled masses think my problem is unrelated to that?

> I think dbus is mandatory for device discovery.  Could someone confirm?

>> I also compiled it on Slackware 12.2 (an infinitely simpler process
>> than for Knoppix, as it turns out, using slight mods of the SlackBuild
>> scripts on

>> Problem 2
>> ---------
>> On Slackware ekiga refuses to see my ov511 web cam, although it is
>> happy with my Logitech web cam (a pwc-based web cam).  Has ekiga given
>> up on older web cams?  This web cam works happily with other video
>> applications on that system.

> Have you libv4l library installed?  If yes, please send the -d 4 output...
I have libv4l-0.5.7 compiled and installed with the Slackware 12.2 slackbuild.

The output is a bit large to include here.  You can get it from

As I recall, older versions of ekiga (or maybe gnomemeeting) got you
to select V4L or V4L2.  I don't see that choice any more.  The camera
that works required, as I recall, V4L2 whereas this one required V4L.
So maybe the code to deal with V4L vs. V4L2 has an issue.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]