[Ekiga-list] No audio plungin found on X64

franz.fuder at ifaz.de franz.fuder at ifaz.de
Sat Dec 16 11:48:51 UTC 2006

Am Sa, 16.12.2006, 11:53, schrieb Damien Sandras:
> Le samedi 16 décembre 2006 à 10:37 +0000, A. James Lewis a écrit :
>> On Sat, 2006-12-16 at 10:44 +0100, Jan Schampera wrote:
>>> On Sat, 16 Dec 2006 01:02:20 +0000
>>> "A. James Lewis" <james at fsck.co.uk> wrote:
>>>> I also found that ekiga doesn't try very hard to find pwlib...
>>>> since pwlib isn't really a "library" as the OS understands it, it
>>>> will not help to add it to ld.so.conf... it looks only where hard
>>>> coded to look, <PREFIX>/lib... I hope this could be a bit more
>>>> flexable at runtime... ekiga could either look at the config,
>>>> ld.so.conf or allow the pwlib location to be configured... I've not
>>>> tried with a 64 bit machine, but this can also be an issue on 32
>>>> bits.
>>> True for the plugins in some way. But PWLib itself is searched and
>>> found by the dynamic linker, it IS a "normal" library.
>> I found that a version of ekiga installed in /usr/local, will not find
>> its pwlib codecs in /usr/lib... I think that mabe there is an arguement
>> for having a few fallback locations if the compile time option is not
>> available.... /usr/lib, /usr/local/lib and the 64 bit equivalents would
>>  be a good start...   Is there any reason not to do this?
> Ekiga does not look for the plugins itself, but PWLIB is doing it,
> independently of the location from which Ekiga is executed.
> When you compile PWLIB, you give a --prefix option (defaults
> to /usr/local/), that option determines where plugins will be installed,
> and where it should look for them.
> If it doesn't find the plugins, it means that :
> - you have not run make install
> - you have conflicting versions installed and the process is not linked
> to the version of the library you expect it to be linked --
> _      Damien Sandras
> (o-
> //\   Ekiga Softphone : http://www.ekiga.org/
> v_/_ NOVACOM         : http://www.novacom.be/ FOSDEM          :
> http://www.fosdem.org/
> SIP Phone       : sip:dsandras at ekiga.net
> _______________________________________________
> ekiga-list mailing list ekiga-list at gnome.org
> http://mail.gnome.org/mailman/listinfo/ekiga-list
My experience is different. I installed with checkinstall and prefix /usr.
All the staff end then in /usr/lib below /usr which is in one sense
correct. However, ekiga is searching the plugins (audio and vidio) in
It is easy to see this, I made just a symbolic link from /usr/lib/pwlib to
/usr/lib64 and this fixes the problem.

For me this is fine, but I suppose a lot of other x64 user will have
problems. Pwlib and opal has different build systems. Pwlib is taking care
of diffrent OS and machtype but opal did not even look at this.

Unfourtunatelly I do not understand enough, if I would I would fix it. I
did it succesfully for pwib but opal donsn't work. so it make no sense to
send the patch.

Checkinstall works fine, I run it also on a 32 bit system and everything
worked fine without any problems, so it is not due to checkinstall it is a
problem with opal and pwlib I guess


More information about the ekiga-list mailing list