Re: [Ekiga-list] Ekiga does not hang up properly

Le vendredi 04 août 2006 à 10:53 +0200, Hannes Ebner a écrit :
> Hi
> I am running Ekiga 2.0.2 on Debian Sarge.
> >From time to time I experience the problem that I hang up and I just
> hear one short beep (instead of three) and then the call status of Ekiga
> freezes. I can push the button as often as I want, Ekiga does not hang
> up. Another side effect is that I cannot receive calls anymore and I
> have to kill Ekiga, a normal exit does not work.

Sounds like an ALSA issue.

> It does not happen so often, but this time I was lucky and could
> reproduce the problem when I had a "-d 4" running, I will send it to
> Damien per PM. You can see the hang-up at the end, with a few calls in
> between.

Nothing wrong in that -d 4 output unfortunately.
Would it be possible when it happens to do this :
ps ax | grep ekiga (try to see the pid)
gdb attach pid
thread apply all bt 
and mail us the bt.

> Right now I'm also investigating another problem. I am able to make
> active calls all the time, but when somebody tries to call me I have to
> be lucky in order to receive it. The caller does not hear anything, no
> ring, nothing. I don't see an incoming call either - I'm trying right
> now to catch this with a "-d 4" as well. It is a bit mysterious, because
> I didn't change my system configuration.

The -d 4 won't help. The problem is on the other side. Notice that the
ring is generated by the remote, not by the called party. Finally, it
could also be due to some NAT issue (the binding expires).
 _      Damien Sandras
//\     Ekiga Softphone:
v_/_    FOSDEM 2006    :
        SIP Phone      : sip:dsandras ekiga net
                         sip:600000 ekiga net

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]