Re: [Ekiga-devel-list] building latest ekiga master

On 30/04/15 13:28, Peter Robinson wrote:
On Thu, Apr 30, 2015 at 10:04 AM, Eugen Dedu <eugen dedu univ-fcomte fr> wrote:
On 29/04/15 12:29, Peter Robinson wrote:

On Wed, Apr 29, 2015 at 10:38 AM, Eugen Dedu <eugen dedu univ-fcomte fr>

On 29/04/15 11:04, Peter Robinson wrote:

Hi All,

I thought I'd try to build the latest ekiga dev on Fedora 22 to see
how it looks (and add a copr build [1] for other interested people)
but I was stumped at the first hurdle.

It seems between ptlib 2.10.x and 2.14.x the build system was changed
around quite a lot and has issues on regular distro style packaging
where things like install directory are specified and don't work any
more. They also use things like old config.guess/config.sub dating
back to 2003 so most new architectures are missing too. I didn't have
much time to spend but overall it seems like some regressions in the
newer ptlib/opal side of things so I thought I'd just give people a
heads up.

Thanks a lot for trying!

Could you be more specific about what "install directory" does not work?
Here on debian ptlib and opal package and install fine.  One note: you
to use "make opt" in ptlib and opal in order for plugins to be installed

It's the same mechanism used to build 2.10 and all preceding releases
for years, as it looking at the git logs from the first release we
used in Fedora back to when it changed name from pwlib to ptlib back
in 2008.

What exactly version of ptlib/opal have you tried (also: release or

ptlib 2.14.3

Could you give me the log of the failed build?  Except updating
config.guess/sub, I do not know what to do.

Full logs at [1] but basically the problem is if I run the "make
install" command below it tries to installer it in /usr/lib64 eveen
though it's explicitly specified.

make PREFIX=/builddir/build/BUILDROOT/ptlib-2.14.3-1.fc23.x86_64/usr


In [1] I see:

+ ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --program-prefix= --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man --infodir=/usr/share/info --prefix=/builddir/build/BUILDROOT/ptlib-2.14.3-1.fc23.x86_64/usr --disable-static --enable-plugins --disable-oss --enable-v4l2 --disable-avc --disable-v4l --enable-pulse

so you specify --libdir=/usr/lib64.

Afterwards I see (as you also wrote):

+ make PREFIX=/builddir/build/BUILDROOT/ptlib-2.14.3-1.fc23.x86_64/usr LIBDIR=/builddir/build/BUILDROOT/ptlib-2.14.3-1.fc23.x86_64/usr/lib64 install

As far as I know, the usual (right?) way is to use PREFIX and LIBDIR with make (as you did), and DESTDIR with make install. I think you need to change the make install command into this:

make DESTDIR=/builddir/build/BUILDROOT/ptlib-2.14.3-1.fc23.x86_64/usr install

What do you think?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]