Re: [Ekiga-devel-list] Ekiga win32 compilation issue with opal (H.264)

Mahesh Sukumar wrote:
Thanks Eugen. Everytime I try to build the latest versions, I get stuck with the x264 problem:

undefined reference to `_x264_nal_encode'

I am able to build the linux and win32 versions using the Ekiga 3.0.0 sources. The only glitch that I see with this is the command-line window that pops up along with the win32 version of Ekiga. I am looking out for the specific changes that were done to avoid this issue.

Look at

Mahesh Sukumar wrote:
Hash: SHA1

Now that the gnome-doc-utils.make problem is solved, I now get an error
with lib/engine/components/opal/sip-endpoint.h

In file included from
.../../../../lib/engine/components/opal/sip-endpoint.h: At global scope:
.../../../../lib/engine/components/opal/sip-endpoint.h:177: error:
expected ‘,’ or ‘...’ before ‘&’ token
.../../../../lib/engine/components/opal/sip-endpoint.h:177: error: ISO
C++ forbids declaration of ‘SIPDialogNotification’ with no type
warning: ‘PPlugin_PNatMethod_STUN_Registration_Static_Library_Loader’
defined but not used
make[7]: *** [opal-gmconf-bridge.lo] Error 1
make[7]: Leaving directory
make[6]: *** [all-recursive] Error 1
make[6]: Leaving directory
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory
make[3]: *** [all] Error 2
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
make[1]: *** [all] Error 2
make[1]: Leaving directory
make: ***
Error 2
mahesh akhanda-bharatham:~/Desktop/ekiga-stable/ekiga-3.0.0/win32$

Do these errors still appear with svn or 3.2.0?

I am able to compile the linux version (Ekiga ver. 3.0.0) without any
trouble while the win32 build throws so many errors!!! Can any one
please tell me the link to the ekiga source snapshot that compiles (both
linux and win32) without these problems?

Will soon be available.

Mahesh Sukumar wrote:
I have disabled x264 in the opal plugins Makefile and hence am able to
get past the reported error. I'm now stuck with the following error on
running the win32 Makefile -
mahesh akhanda-bharatham:~/Desktop/ekiga-stable/ekiga-3.0.0/win32$ make
Running automake-1.10...
automake-1.10: cannot open < gnome-doc-utils.make: No such file or directory
make: ***

I do not understand why the others do not have this error...

Mahesh Sukumar wrote:
I still get almost the same error (after setting CFLAGS and CXXFLAGS to
--verbose -save-temps)
I am using 64bit Ubuntu (and therefore 64bit H.264 libs and libs-dev)
for this cross compilation. Can this be a cause for this problem?

Maybe.  Look at opal-svn/plugins/video/H.264/shared/h264frame.cxx:

  #ifndef _WIN32
    #include "../gpl/enc-ctx.h"
    #include "../gpl/x264loader_unix.h"
    extern X264Library X264Lib;
    #define X264_NAL_ENCODE x264_nal_encode

I suppose it's because you do not have _WIN32 defined. Could you check please? You can also look at ../gpl/enc-ctx.h, line
  #define X264_NAL_ENCODE X264Lib.Xx264_nal_encode
if you can...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]