dogtail-devel [Bug 377298] dogtail is not localized

If you have any questions why you received this email, please see the text at
the end of this email. Replies to this email are NOT read, please see the text
at the end of this email. You can add comments to this bug at:

  dogtail | Framework | Ver: unspecified

------- Comment #23 from Michal Babej  2007-11-29 13:32 UTC -------
(In reply to comment #22)
> OK, I updated patch. Please review the patch.
I'm looking at it now.

> Do you mean dogtail does not use glib2-devel if my patch is not applied?
> I applied it at the moment but actually I have been thinking the patch will be
> applied when the maitainer resolves the build issue.
> > where it fails with some AM_ macro undefined. 
> Which macro is not defined? it maybe automake/autoconf is old.

No, auto* is fine. This is how it fails:
+ aclocal warning: macro `AM_GLIB_GNU_GETTEXT' not found in
+ autoconf error: possibly undefined macro: AM_GLIB_GNU_GETTEXT
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
error: Bad exit status from /var/tmp/rpm-tmp.44707 (%build)

And that's because AM_GLIB_GNU_GETTEXT is defined in this file:
which belongs to glib2-devel.

> Does your .spec file has "BuildRoot: " in the header?

I used the specfile you provided in your previous patch. This is not the issue;
see my next answer.

> > Have you tried it in some linux ?
> Yes, the patch works fine with RHEL4 and Fedora 7.

Let me guess - you're running rpmbuild as root. That's why it works for you and
fails for me. It's a bad practice - if you had a screwed specfile, it could
screw up your system. In this case, it merely overwrites system's dogtail. When
i run rpmbuild:

rpmbuild runs %install:

+ make DESTDIR=/var/tmp/dogtail-0.6.2-2-root-mike install
list='po recorder sniff'; for subdir in $list; do \
          (cd $subdir && make DESTDIR=/var/tmp/dogtail-0.6.2-2-root-mike
install) \
        done; \
        python install

             ^^^^^^^^^^^^ this is the problem
... right after make, it runs "python install":

running install
running build
running build_py
running build_scripts
running install_lib
copying build/lib/dogtail/ -> /usr/lib/python2.4/site-packages/dogtail
error: could not delete '/usr/lib/python2.4/site-packages/dogtail/':
Permission denied
make: *** [install] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.71489 (%install)

It tries to overwrite my system's dogtail, and it fails since i'm not root. So,
the problem is in dogtail's Makefile. I fixed it; see my next patch.

> > Could you be more specific ?
>  - gettext.install does not work GUI translation.
Uh, sorry, i don't understand. What doesn't work ?

>  - bindtextdomain needs to set the locale dir.

>  - Some of .py loose '_' macro. It causes execution errors.
>  - The single quotation does not work with intltool which is used by many
> translators.
>  - gnome.ui needs to be loaded.

> Yes, I put the sniff and dogtail-recorder is saved in at the moment
> however I think that finally we need to renamed sniff to in the source
> files so that intltool-update can detect the file.

No, i think you miss my point.

> > Unfortunately python's support for i18n isn't all-star either.

> I think when the python official package is available, the option is
> considered. At the moment, none python intltool is available and it's used by
> several python applications, gnome-menus, orca and etc.

Good news:

See for more info about why you received
this email, why you can't respond via email, how to stop receiving
emails (or reduce the number you receive), and how to contact someone
if you are having problems with the system.

You can add comments to this bug at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]