Re: [External Deps] Issue in libtelepahy deps


libtelepathy is being replaced by telepathy-glib. Currently libtelepathy
0.3.1 depends on telepathy-glib 0.7.0 and Empathy depends on both.
telepathy-glib 0.7.1 will contain everything needed to drop libtelepathy
dependency but it will take some time to adapt Empathy and
MissionControl to the new API.

So for now both libtelepathy and telepathy-glib are external dep for
Empathy but libtelepathy will be deprecated at some point.

Xavier Claessens.

On ven, 2007-12-14 at 15:59 +0100, Luca Ferretti wrote:
> Building meta-gnome-proposed in jhbuild, I found a "hole" in external
> deps. 
> Currently empathy is proposed for 2.22, suggesting[1] libtelepaty and
> libmissioncontrol as external deps[2].
> But in order to build libtelepathy you need "telepathy-glib" too; this
> module isn't prosed for inclusion as ext dep for 2.22.
> Question A: should we consider telepathy-glib a proposed dep?
> Question B: if the answer to previous question is yes, OK to update wiki
> pages and jhbuild modulesets?
> Question C: shouldn't we use released packages for external deps
> (currently all *telepathy* packages are grabbed from version control)?
> [1]
> [2] while both not listed as suggested in    

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]