CVS/JHBuild complaints

This weekend I have tried to build Yelp and all it's dependencies from jhbuild. I ran in to quite a few problems, so I'm complaining publicly here (I know Jeff will hate me for this):

* avahi depends on libgdbm;  libgdbm-dev needs to be installed for avahi
Do we currently have a list of "external" development libraries that
need to be installed in order to compile from JHBuild?  I know there are
some recommendations at in the
section "How to prepare your system for Development?"  but this is 1)
not distribution agnostic and 2) relatively unmaintained.  Perhaps this
could be one of the Build Brigade's responsibilities?

* libpam0g-dev needs to be installed for PolicyKit to build; same as

* avahi depends on libglade; need to modify the gnome-2.16 moduleset to reflect this dependency

* avahi depends on pygtk (and pycairo, pygobject); need to modify gnome-2.16 moduleset to reflect this dependency

* avahi depends on dbus-python and dbus-glib bindings set; dbus-python and dbus-glib are now in a git repository (bug 347674); need to add to modulesets and add appropriate dependencies

* dbus-python depends on Pyrex for bindings which aren't included in jhbuild bootstrap

* dbus-glib fails compilation due to automake failing because of a missing 'ChangeLog' (f.d.o bug 7540)

* dbus-glib/test/glib/test-service-glib.h fails compilation due to a missing include file (f.d.o. bug 7589)

* dbus-glib doesn't install dbus-glib.h include file (f.d.o. bug 7562)

* PolicyKit needs --disable-docbook-docs, or make fails due to missing command "no" (f.d.o. bug 7161)

* PolicyKit needs --with-pam-module-dir=prefix + '/lib' so it doesn't try to install into /lib

* libvolume_id needs to be installed for hal; should this be part of jhbuild bootstrap or should the user be responsible for installing the development package from their distro? I ended up getting around this by doing the following:

cvs -d :pserver:anonymous anoncvs freedesktop org:/cvs/hal co -D 'Jul 10 18:30:00 2006 UTC' hal

Can we please get these fixed or at least somebody looking at these? The dbus bindings split seems to be causing the most problems.

Thank you,

Brent Smith  <gnome nextreality net>
IRC: smitten / #docs /

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]