Re: Problem with compiling GNOME 2.5

On 2004-02-13(Fri) 13:05:20 +0800, James Henstridge wrote:
> >I have been using jhbuild to compile GNOME HEAD from cvs.
> >Recently, metacity and nautilus were acting very sluggishly, and after
> >some poking around, I found out that the files that were being installed
> >in $prefix/lib were missing the *.so extension.
> >I am running Mandrake 9.2.
> >
> This problem occurs when aclocal finds the libtool.m4 from one version 
> of libtool, and the libtoolize script installs an from another 
> version (the two versions are probably 1.4.x and 1.5.x).  These combine 
> to create a non-working libtool script that installs shared libraries 
> without extensions.
> I'd suggest modifying ACLOCAL_FLAGS and/or PATH so that the right files 
> get chosen.

Or simply avoid running libtoolize at all if possible. Yes, Mandrake 9.2
comes with libtool 1.4.3, which will fail miserably when trying to
overwrite the libtool 1.5 bundled with various gnome tarballs.


> James.
> -- 
> Email: james daa com au
> WWW:
> _______________________________________________
> desktop-devel-list mailing list
> desktop-devel-list gnome org

Abel Cheung
Linux counter #256983   |
GPG Key: (0xC67186FF)   |
Key fingerprint: 671C C7AE EFB5 110C D6D1  41EE 4152 E1F1 C671 86FF

Attachment: pgp65vnXJPthz.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]