Re: Enforcing use of NEWS

Hi Murray,

On Thu, 2003-01-02 at 06:13, Murray Cumming wrote:
> GNOME package maintainers often don't use NEWS, so the GNOME release 
> announcements are vague. The release-team would like
> people to use NEWS, and we might even modify's install-module 
> script to read NEWS files automatically.
> In the meantime, Daniel Elstner pointed out to me that automake (probably >= 1.6)
> has a check-news feature. I suggest that people use it.
> <danielk> murrayc: BTW regarding up-to-date NEWS files: recent automakes
> have a check-news option that's triggered on make dist.  I'm using it in
> regexxer
> <danielk> AM_INIT_AUTOMAKE([check-news]) is all you need to set it
> globally
> <danielk> It just checks whether the current version number appears in
> the first few lines of NEWS.

	I think this is only for automake > 1.7.x. It certainly doesn't
work with 1.6.2 anyway ..

Good Luck,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]