Gconf: how to install .schemas files via autotools


I just ported my app to gconf. Everything worked fine so far. However I
have problems with installing the .schemas files. Not really installing,
because this works fine, but gconftool never gets executed when I do a
make install :-(

I have this in my Makefile.am:

schemadir = $(sysconfdir)/gconf/schemas
schema_in_files = gnomeradio.schemas.in
schema_DATA = $(schema_in_files:.schemas.in=.schemas)

EXTRA_DIST = [...]
             $(schema_DATA) \

--makefile-install-rule $(top_srcdir)/gnomeradio.schemas

and this in my configure.in:

AC_PATH_PROG(GCONFTOOL, gconftool-2, no)

if test x"$GCONFTOOL" = xno; then
  AC_MSG_ERROR([gconftool-2 executable not found in your path - should
be installed with GConf])


Am I missing something?

When I do a make install, I only get:

make[2]: Nothing to be done for `install-exec-am'.
/bin/sh ./mkinstalldirs /home/mfcn/garnome/share/applications/
 /usr/bin/install -c -m 644 ./gnomeradio.desktop
/bin/sh ./mkinstalldirs /home/mfcn/garnome/etc/gconf/schemas
 /usr/bin/install -c -m 644 ./gnomeradio.schemas
make[2]: Leaving directory `/home/mfcn/src/gnomeradio2'
make[1]: Leaving directory `/home/mfcn/src/gnomeradio2'

Maybe someone can enlighten me,

PS: if I use autogen.sh or autoreconf, then autoconf complains about the
macro AM_GCONF_SOURCE_2 not beeing defined. But its defined in
/gnome2/installpath/share/aclocal/gconf-2.m4. I copied over this file
into sourcedir/macros and did a autoheader;aclocal -I
macros;autoconf;automake and this worked fine. What's wrong here?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]