Re: problem with xmldocs.make with new automake

On Sat, Mar 16, 2002 at 10:16:11PM +0800, James Henstridge wrote:
> John Fleck wrote:
> >On Sat, Mar 16, 2002 at 10:58:59AM +0800, James Henstridge wrote:
> >
> >>Hi John,
> >>
> >>I ran into some troubles with your xmldocs.make infrastructure with 
> >>automakes 1.6.  New automake actually processes include statements 
> >>itself, and includes the contents (so the includes actually get 
> >>processed as automake input).  Unfortunately there is a bug in this 
> >>code, which trips up on this section:
> >>  $(docname).xml: $(entities)
> >>          -ourdir=`pwd`;  \
> >>          cd $(srcdir);   \
> >>          cp $(entities) $$ourdir
> >>
> >>It trips up on the line with the equals sign, and treats it as a 
> >>variable definition (and reorders it out of the rule).  The bug has been 
> >>reported to the automake guys:
> >>  
> >>
> >>
> >
> >Is there a fix we need to make to xmldocs.make to work around this?
> >
> Damn.  Did a little more investigation, and it looks like it isn't an 
> automake bug, but a problem in the xmldocs.make file afterall.
> The problem occurred in the following rule:
>   $(docname).xml: $(entities)
>           -ourdir=`pwd`;  \
>           cd $(srcdir);   \
>           cp $(entities) $$ourdir
> I didn't notice it at first, but you seem to have used 8 spaces to 
> indent the commands, rather than a tab.  Changing to use spaces makes 
> the problem go away (if it worked previously, then it was a fluke ...). 
>  I don't know where all the copies of this file are in CVS, so I will 
> leave it up to you.

I can go through and fix these, but I'd like to wait until we hear
from Dan Mueth, who wrote xmldocs.make in the first place. Don't know
if he's on this list - I've cc'd him.


P.S. Jody, this is your cue to say "I told you so." :-)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]