Hacking deja-dup


I'd like to add some functionality to deja dup (hopefullly!), so I'm
following the wiki page:


I've found a couple of problems on 12.04:

 - for some reason I had valac-0.12 installed (may be because I upgraded
from previous Ubuntu version?), and I had to install valac-0.16
explicitly (the page mentions valac only, and it configure failed)
 - libpeas-dev needs to be installed and it's not mentioned in the page

After that everything seems OK, but I haven't found a way of running the
built binaries without installing them.

I've tried to run ./preferences/deja-dup-preferences from the project
directory and it complains about being unable to start the backup tool
(Could not find backup tool in /usr/local/libexec/deja-dup/tools.  Your
installation is incomplete.); Ubuntu has nothing on that path or
/usr/libexec/... for that matter.

I tried to use a PREFIX in my home directory, but it doesn't work either.

Is there any way of running the application without installing it?

Kind regards,


Juan J. Martinez
Development, MEMSET

mail: juan memset com
 web: http://www.memset.com/

Memset Ltd., registration number 4504980. 25 Frederick Sanger Road,
Guildford, Surrey, GU2 7YD, UK.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]