Re: beagle problem

> > > (yelp:11000): Yelp-WARNING **: beagled not running, using basic
> > > search support.
> > > but beagled is running.
> > > This happens with beagle 0.3.1 and yelp 2.20.0 under Ubuntu 7.10.
> >
> > This is probably the same issue as libbeagle0 vs libbeagle1. yelp
> > needs to be rebuilt with libbeagle1 [1].
> I compiled yelp with the suggested correction, but it still complains
> that beagled is not running. Perhaps there is something else to change
> in the yelp's source, but at this point I think it's a task for yelp's
> developers.

Hmm... I tried yelp on gutsy and it was refusing to see the running beagled. 
Then I tried
$ nm -D /usr/bin/yelp | grep beagle_
and it listed a lot of functions but not the crucial one beagle_client_new 
(which, according to the websvn code, is inside a #ifdef). I have no idea 
what it means since some of the other functions inside the #ifdef do show up 
in the symbol list.
I suggest filing a bug with yelp. Most likely something is wrong there.

- dBera

Debajyoti Bera @
beagle / KDE fan
Mandriva / Inspiron-1100 user

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]