Re: CVS Beagle doesn't build correctly

On Tue, 03 Aug 2004 08:48:57 -0400, Joe Shaw wrote
> Hi,
> On Tue, 2004-08-03 at 21:42 +1200, Michael A. Koziarski wrote:
> > When I run make I get the following error (Full log in Filters-Failure.log):
> > 
> > ** (/usr/lib/mono/1.0/mcs.exe:5497): WARNING **: Could not find assembly 
> > evolution-sharp, references from 
> > /home/michael/cvs/gnome2/beagle/Filters/../indexer/Indexer.dll 
> > (assemblyref_index=5)
> >       Major/Minor: 1,0
> >       Build:       0,0
> >       Token:       457eed85bd9370df
> > 
> > 
> > Now looking at the mcs command used to compile it, I can see there's no 
> > reference to evolution sharp.
> This is the compiler looking in the GAC to try to resolve the reference
> to evolution-sharp from Indexer.dll.  This is probably something that
> should be fixed in the Makefile, but I've taken to doing:
> MONO_GAC_PREFIX=/opt/evolution-sharp make
> which should take care of it.  Note that it's the *prefix* to evo-sharp
> and not any specific library path.  So if you installed into
> /usr/local, you'll want to set that there.
> Joe

I seem to be having a similiar issue.  The patch I'm working on requires
XmlRpcCS.dll which gets put into /usr/local/lib/mono/XmlRpcCS/ by the gacutil.
 I have mirrored the code in the makefiles and from the
evolution-sharp code.  So I'm guessing my MONO_GAC_PREFIX would be /usr/local/
but I still get a similar error as above when doing that.  Anyone have some
hints on what might be tripping me up?  Specifically here is the error:

** (/usr/lib/mono/1.0/mcs.exe:9067): WARNING **: Could not find assembly
XmlRpcCS, references from /home/joe/code/beagle/beagled/../indexer/Indexer.dll
     Major/Minor: 1,10
     Build:       1671,27311
     Token:       03764c778e192885

-- Joe Gasiorek
gasiorek yakko cs wmich edu

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]