[libshumate] Created tag 1.0.0.alpha.1
- From: Corentin Noël <corentinnoel src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [libshumate] Created tag 1.0.0.alpha.1
- Date: Thu, 13 Jan 2022 19:58:14 +0000 (UTC)
The unsigned tag '1.0.0.alpha.1' was created.
Tagger: Corentin Noël <corentin noel collabora com>
Date: 1642103874 +0100
Version 1.0.0.alpha.1
Changes:
Andy Holmes (3):
ShumateLicense: enable text wrapping
ShumateMarkerLayer, ShumatePathLayer: disconnect from viewport
vector-style: Avoid int multiplication overflow
Bilal Elmoussaoui (1):
readme: mention the docs
Chris Mayo (1):
docs: Install into datadir / 'doc'
Corentin Noël (90):
meson: Fix vapi generation
shumate-viewport: Modernise the codebase
shumate-view: Modernise the codebase
shumate-tile: Modernise the codebase
shumate-marker: Modernise the codebase
shumate-layer: Modernise the codebase
shumate-bounding-box: Modernise the codebase
shumate-coordinate: Modernise the codebase
shumate-map-source: Modernise the codebase
shumate-tile-cache: Modernise the codebase
shumate-tile-source: Modernise the codebase
shumate-scale: Modernise the codebase
shumate-map-source-factory: Modernise the codebase
shumate-point: Modernise the codebase
shumate-network-tile-source: Modernise the codebase
shumate-label: Modernise the codebase
shumate-file-cache: Modernise the codebase
shumate-renderer: Modernise the codebase
shumate-image-renderer: Modernise the codebase
shumate-marker-layer: Modernise the codebase
shumate-error-tile-renderer: Modernise the codebase
shumate-memory-cache: Modernise the codebase
shumate-map-source-desc: Modernise the codebase
shumate-map-source-chain: Modernise the codebase
shumate-license: Modernise the codebase
shumate-path-layer: Modernise the codebase
shumate-location: Modernise the codebase
shumate-null-tile-source: Modernise the codebase
demos: Only enable the minimal demo and make it build with Gtk4
docs: Replace Clutter with Gtk
Remove ShumateCairoExportable and ShumateCairoImportable interfaces
shumate-tile: Replace cairo_texture_t with GdkTexture
shumate-error-tile-source: Rename ShumateNullTileSource into ShumateErrorTileSource
shumate-map-source: Remove ShumateRenderer and render the tiles directly within the MapSource
demos: Do not use GtkContainer in the minimal demo
view: Remove the DEBUG macro and comment unused code
view: Reuse the GParamSpec instead of using the property name
delete shumate-private.h
Remove unused pkg-config files
layer: Make it a subclass of GtkWidget
tile: Make it a subclass of GtkWidget
map-layer: Create ShumateMapLayer
tile: Align the syntax with the one used in many GNOME projects
meson: Update pkgconfig to use the built-in features
scale: Port to Gtk4
license: port to Gtk4
demos: Make the default demos build with master
marker: Make it a GtkWidget subclass and simplify it
path-layer: Remove old and unused code and prepare for GTK4
view: Remove old and unused code
point: Make it a simple widget and style it with CSS
Remove ShumateLabel
marker: Make the selection API private
tile: Add CSS class
layer: Add CSS class
docs: Update the documentation to the available types
map-source: Add a way to cancel the request of a Tile
map-layer: Fix the position of the tiles
view: Add GtkGestureDrag handler to the view
view: Add scroll controller to the view
viewport: Rewrite the ShumateViewport and all the Layers to synchronize around a common ShumateViewport
widget
Cleanup the source tree
Make the Vala demos build
Remove shumate-defines.h
Add tests
location: always specify that the longitude and latitude are in degrees
map-source: Make converting latitude <-> y and longitude <-> x more accurate
view: Zoom-in and out centered on the mouse position
scale: Use hardcoded string for style class
Get rid of unneeded glib types
shumate-bounding-box: Remove ShumateBoundingBox
doap: Add myself as maintainer
map-source-desc: Make it usable with bindings
scale: Allow to modify the viewport after creating the scale
map-source: Change to a GObject subclass
map-source-registry: Replaces map-source-factory and cleanup unused types
docs: Add more documentation
ci: Publish coverage report
Change default branch to main
map: Rename ShumateView into ShumateMap
map-source: Make this class capable
compass: Add ShumateCompass
Version: Remove useless elements
meson: Remove config.h
NetworkTileSource: Remove variable leftover
Location: Document and annotate MIN/MAX lontitudes and longitudes
demos: Only build protobuf for cpp and use Shumate main branch
map-source: Add fill_tile_finish to allow subclassing it.
misc: Fix various documentation warnings
Release 1.0.0.alpha.1
Georges Basile Stavracas Neto (45):
marker-layer: Rework allocation
marker-layer: Rename set_marker_position() to update_marker_visibility()
view: Set overflow to HIDDEN
marker: Add GTK4-style child API
tests: Use a foreach loop in meson.build
tests: Add new marker test for the new API
viewport: Only notify if property changed
viewport: Fix min zoom level check
viewport: Clamp zoom level after updating min/max levels
viewport: Mark properties as EXPLICIT_NOTIFY
viewport: Validate min and max zoom levels
tests: Add viewport tests
marker-layer: Properly position markers
marker-layer: Floor down x/y
tests: Remove unused fatal log handler
view: Remove unused macro
view: Add API to set the go-to animation duration
view: Make go-to duration naming consistent
view: Reimplement animated go-to using tick callbacks
view: Use quark for detailed signal
view: Trivial code shuffling
view: Rename variable to clarify unit
view: Impove input checks of shumate_view_go_to()
view: Trivial code cleanup
view: Stop using GSlice
view: Fix longitude validation check
view: Generalize moving viewport from offsets
view: Add kinetic scrolling
view: Remove 'deceleration' property
view: Remove 'kinetic-mode' property
view: Fix scroll-to-zoom direction
map-layer: Rework tile allocation
map-layer: Queue idle relayout if grid needs recomputing
map-layer: Trivial cleanup
map-layer: Use row & column terminology when dealing with tiles
map-layer: Allocate columns, then rows
map-layer: Rename some variables
map-layer: Shift row and columns when possible
memory-cache: Stop using g_slice_*
memory-cache: Reuse GdkTexture
memory-cache: Use only GdkTexture
tests: Add some tests for ShumateMarkerLayer
marker-layer: Implement shumate_marker_layer_remove_all()
marker-layer: Also monitor markers' longitude
marker-layer: Use g_signal_connect_object() to connect to markers
James Westman (93):
demos: Create a Flatpak manifest
view: Fix bug when zooming in/out
file-cache: Propagate GCancellable
Add CI
demos: Build docs in the demo Flatpak
marker-layer: Initialize `mode` property correctly
map-layer: Fix bug in tile grid update
view: Add insert_layer_(behind/above)
tests: Add tests for view add/remove/insert
scale: Update when the reference map source changes
tests: Add tests for ShumateMarkerLayer
Rewrite ShumateMarkerLayer selection logic
demos: Remove unused files
demos: Delete all demos except minimal
demos: Use UI files for the demo
demos: Add markers and paths to demo
demos: Add ShumateTestTileSource
demos: Create scale in UI file
meson: Remove unused config file
file-cache: Add methods to store/retrieve raw data
network-tile-source: Use its own file cache
file-cache: Remove as a map source
tests: Add test for file cache ETags
docs: Update FileCache and NetworkTileSource docs
file-cache: Don't rely on storing data in the tile
Use g_task_is_valid instead of G_IS_TASK
network-tile-source: Fix crash when cancellable is NULL
map-source: Add fill_tile_async
Add a simple ShumateNetworkTileSource test
memory-cache: Add methods to store/retrieve tiles
map-layer: Use an internal memory cache
memory-cache: Remove as a map source
Remove ShumateTileCache
Clean up gitignore
file-cache: Make store_tile asynchronous
map-source: Make the fill_tile vfunc async
Remove ShumateErrorTileSource
Remove ShumateMapSourceChain
map-source: Remove :next-source
tests: Make TestTileServer an object
network-tile-source: Throw error if URL is invalid
tests: Add ShumateNetworkTileSource tests
map-source: Update documentation
file-cache: Return tile modification time
network-tile-source: Use modtime from file cache
tile: Remove modified-time and etag
file-cache: Fix bug when updating tiles
tests: Listen only on IPv4
network-source: Render expired cache data
network-tile-source: Reorder async callbacks
network-tile-source: Minor fixes
Use doubles for zoom level
map-layer: Implement continuous zoom
ci: Update Docker container
marker: Remove global selection color variables
view: Add trackpad/touchscreen zoom support
Use g_debug() instead of custom debug macro
file-cache: Remove shumate_file_cache_purge_on_idle
file-cache: Make purge method async
file-cache: Minor cleanup
file-cache: Automatically purge the cache
scale: Fix background color on dark themes
license: Improve readability
docs: Switch to gi-docgen
view: Remove overlay sources
map-layer: Use hash table instead of pointer array
map-layer: Move logic out of size_allocate
tile: Use widget size rather than texture size
map-layer: Fix flashing when zoom level changes
Add support for rotation
network-tile-source: Read into a GBytes
license: Handle null license text
Fix zoom formula
network-tile-source: Fix offline usage
network-tile-source: Use g_object_notify_by_pspec
map: Fix memory leak
map: Make viewport a read-only property
vector: Add ShumateVectorStyle
vector: Add ShumateStyleError
vector: Add JSON utilities
vector: Add background layer
vector: Add fill layer
vector: Add line layer
vector: Add expression system
vector: Add filter expressions
license: Get license info from the map
flatpak: Don't build docs
vector: Hide behind a build flag
Split ShumateNetworkTileSource
compass: Fix error when connecting signals
Add libsoup3 support as a build option
Revert "license: Get license info from the map"
Add ShumateSimpleMap
Marcus Lundblad (38):
Initial import from libchamplain
Remove Autotools build support
Remove Mephis renderer
Remove GTK-Champlain widgetery
Add build directory to .gitignore
Change library name
Remove left-over PackageConfig files for the GTK widgetary library
Rename API
Fix documentation build
Add build-dependency on GTK+ 4
Update copyright
Add myself to AUTHORS
Remove deprecated CustomeMarker
Remove ShumateFileTileSource
Remove Since tags
docs: Remove version index
map-source-factory: Remove deprecated sources
view: Remove deprecated method
Split Exportable interface
debug: Remove left-over Memphis renderer flags
map-source-factory: Remove left-over Memphis renderer code
renderer: Use guint8, not gchar for set_data
cairo-exportable: Use correct documentation section
docs: Refer to the new Cairo interfaces
Remove static .vapi file
Start converting ShumateView into a GtkWidget
marker: Convert to a GtkWidget
Remove ShumateNetworkBboxTileSource
Merge branch 'master' into 'master'
Merge branch 'wip/nielsdg/fix-meson' into 'master'
Merge branch 'wip/nielsdg/const' into 'master'
Merge branch 'wip/tintou/modern-codebase' into 'master'
Add Niels De Graaf and Corentin Noël to AUTHORS
Add DOAP file
Add basic README
path-layer: Add ability to set outline
scale: Avoid overflowing float multiplication
test-tile-source: Avoid int mulitplication overflow
Niels De Graef (5):
meson: Fix gtk4 dependency
Don't use G_CONST_RETURN
Don't use GTimeVal
marker: Comment functions which are broken in GTK4
docs: Update gi-docgen annotations
TAO ZUHONG (1):
Fixed build error under MSYS2 on Windows
Valentin Blot (1):
fixed build
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]