[gtkmm] Gtk::ShortcutController: Add get_scope()
- From: Kjell Ahlstedt <kjellahl src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gtkmm] Gtk::ShortcutController: Add get_scope()
- Date: Sun, 23 May 2021 07:20:52 +0000 (UTC)
commit edd57d8758ea74d839806446d4ce2a42f0f8386a
Author: Kjell Ahlstedt <kjellahlstedt gmail com>
Date: Sun May 23 09:15:11 2021 +0200
Gtk::ShortcutController: Add get_scope()
and deprecate the misnamed set_scope() overload.
gtk/src/shortcutcontroller.hg | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
---
diff --git a/gtk/src/shortcutcontroller.hg b/gtk/src/shortcutcontroller.hg
index 67cc864c..811de2a2 100644
--- a/gtk/src/shortcutcontroller.hg
+++ b/gtk/src/shortcutcontroller.hg
@@ -99,7 +99,8 @@ public:
gtk_shortcut_controller_get_mnemonics_modifiers)
_WRAP_METHOD(void set_scope(ShortcutScope scope), gtk_shortcut_controller_set_scope)
- _WRAP_METHOD(ShortcutScope set_scope() const, gtk_shortcut_controller_get_scope)
+ _WRAP_METHOD(ShortcutScope set_scope() const, gtk_shortcut_controller_get_scope, deprecated "Use
get_scope() instead.")
+ _WRAP_METHOD(ShortcutScope get_scope() const, gtk_shortcut_controller_get_scope, newin "4,2")
// gtk_shortcut_controller_add_shortcut() does not take a ref (transfer full).
#m4 _CONVERSION(`const Glib::RefPtr<Shortcut>&', `GtkShortcut*', `Glib::unwrap_copy($3)')
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]