[gtk] Created tag 4.3.2
- From: Matthias Clasen <matthiasc src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gtk] Created tag 4.3.2
- Date: Sun, 25 Jul 2021 02:25:15 +0000 (UTC)
The unsigned tag '4.3.2' was created.
Tagger: Matthias Clasen <mclasen redhat com>
Date: 1627179891 -0400
4.3.2
Changes since the last tag '4.3.1':
Adrien Plazas (2):
gtk: Define the GtkListItem autocleanup func
gtk: Define the GtkListItemFactory autocleanup func
Alexander Mikhaylenko (7):
button: Reset style classes when setting arbitrary children
menubutton: Reset label when setting icon name and vice versa
menubutton: Remove a random g_return_if_fail()
menubutton: Add a way to always show arrow with image buttons
menubutton: Don't hardcode label<->arrow spacing
scrolledwindow: Don't check drag threshold when already scrolling
text: Use the widget y coordinate for gestures
Benjamin Otte (65):
cellarea: Don't shrink area too much
spinner: Behave like any other icon
Merge branch 'wip/otte/for-master' into 'master'
icontheme: Fix binding annotation
Merge branch 'rerename-mediastream' into 'master'
rendernodeparser: Don't use %g when writing file
rendernodeparser: Remove leftover debug prints
Merge branch 'wip/otte/for-master' into 'master'
testsuite: Add test for crasher
cssimagecrossfade: Don't abort() when failing to parse image
Merge branch 'wip/otte/for-master' into 'master'
build: Set proper defaults for media backends
build: disable Vulkan by default
build: Remove sassc option
build: Make all X11 extensions mandatory
x11: Remove unused headers
x11: Remove XComposite
build: Build demos before tools
x11: Move code where it belongs
x11: Remove unused function
x11: Stop reordering visuals
x11: Reorder code
x11: Don't share cached GLX visuals with GTK3
x11: Initialize GL at startup
glx: Don't initialize GLX multiple times.
x11: Move function call
x11: Simplify code
x11: Pass the display, not the screen
x11: Move the EGL display into the private struct
x11: Store the EGL config in the display
x11: Store the EGL surface in the GdkSurfaceX11
x11: Move GL init code into the GL context
glx: Remove Visual cache
x11: Rework Visual selection
x11: Remove GdkVisual
x11: Remove the dummy surface
Revert "x11: Always fall back to GLX on NVIDIA"
x11: Remove unused struct member
x11: Remove glx version check
x11: Use single GLX fbconfig and store it in the display
x11: Store the GLX drawable in the surface
x11: Get Visual from EGL directly
x11: Do not call glXQueryExtension()
x11: Properly record the error when initializing GL
x11: Redo choice between EGL and GLX
gdk: Add a private struct to GdkDisplay
gdk: Allow GdkDrawContext with a %NULL surface
wayland: Move fbconfig into the display
wayland: Don't pass GL config to get_egl_surface()
gdk: Add GdkDisplay::init_gl vfunc
gdk: Require EGL version 1.4 across the board
ngl: Store the shared driver in the display
gdk: Add gdk_gl_context_is_shared()
gl: Deprecate gdk_gl_context_get_shared_context()
gl: Store the context::in-frame state in the current context
gdk: Get rid of paint contexts
gl: Require EGL_KHR_surfaceless_context with egl
gl: Move vfunc
gdk: Move GL context construction to GdkGLContext
inspector: Add support for displaying GL errors
x11: Move code from GdkGLContextX11
display: Move GL selection code into gdkdisplay-x11.c
gl: Fix issue with EGL + nvidia
glx: Get rid fo DrawableInfo
Merge branch 'wip/otte/gleanup' into 'master'
Caolán McNamara (1):
make testdnd trashcan work again
Carlos Garnacho (1):
Merge branch 'fix-pointer-gestures-kde-plasma' into 'master'
Christian Hergert (12):
window: clear move_focus when focus is already set
inspector: fix compilation with broadway
macos: register known clipboard types for drag destination
macos: fix position of drag surface
macos: move drag motion to GdkMacosDrag
macos: check for GdkMacosBaseView before using as such
macos: make pasteboard usage reusable
macos: implement GdkDrop for macOS
textview: give application developers access to RTL and LTR context
texthistory: hoist single actions from group
joinedmenu: add helper to join menus instead of nesting
texthistory: fix calculation of n_chars
Chun-wei Fan (11):
gdksurface-win32.c: Fix formatting for popup functions
gdksurface-win32.c: Fix up popup placement
gdkdrag-win32.c: Fix drag surface positioning
gdksurface-win32.c: Create all surfaces with CS_OWNDC
GDK-Win32: Clean up HiDPI support and WGL a bit
GDK-Win32: Move some functions out of gdkglcontext-win32.c
GDK: Add debug option for WGL usage
Split out WGL/EGL stuff and simplify things
GDK-Win32: Fixup, and cleanup WGL HDC handling
GDK-Win32: init_gl(): Default to WGL for now
gdkdisplay-win32.c: Don't call ReleaseDC() unnecessarily
Emin Tufan Çetin (1):
Update Turkish translation
Emmanuele Bassi (10):
Never show the Trash in the FileChooserWidget side bar
Revert "Never show the Trash in the FileChooserWidget side bar"
Never show the Trash in the FileChooserWidget side bar
Merge branch 'migration_patch' into 'master'
Merge branch 'gtklistitem-autocleanup' into 'master'
docs: Use code blocks for inline XML
Merge branch 'ebassi/issues-4076' into 'master'
Merge branch 'gi-fixes' into 'master'
Merge branch 'doc-fixes' into 'master'
Merge branch 'no-pposition' into 'master'
Florentina Mușat (2):
Update Romanian translation
Update Romanian translation
Florian Müllner (2):
text: Add API to compute cursor extents
gdk/x11: Do not set PPosition hint
Hugo Carvalho (2):
Update Portuguese translation
Update Portuguese translation
Jaap aarts (1):
Add section about `gtk_widget_set_app_paintable`
Jeremy Tan (1):
gdkkeys-win32.c: fix initialisation of key_state in update_keymap
Marc-André Lureau (4):
Add missing "Since: 4.X" tags
Add GTK_DEBUG_ICONFALLBACK Since: 4.2 annotation
Add GtkMenuButton:primary Since: annotation
gtk: fix GtkPasswordEntryBuffer introspection
Marco Melorio (1):
doc: Syntax fixes
Marco Trevisan (Treviño) (2):
build: Get typelib dir dynamically using gobject-introspection dependency
textbtree: Initialize to zero the tags counting array
Matthias Clasen (168):
tests: Fix check vs toggle button confusion
Fix the GAction test
testgaction: Add more widgetry
button: Add a private getter for the action helper
togglebutton: Fix actionable state tracking
checkbutton: Fix actionable state tracking
Merge branch 'actionable-fixes' into 'master'
Merge branch 'wip/chergert/fix-delayed-focus' into 'master'
docs: Fix a typo in the migration guide
docs: Mention the GtkWidget.destroy vfunc
selectionfiltermodel: Fix an oversight
Add tests for empty list models
Merge branch 'listmodel-get-item' into 'master'
Add type annotations for filename arguments
Merge branch 'msvc-fix' into 'master'
Merge branch 'filename-annotations' into 'master'
listitemwidget: Match activation conditions
listitemwidget: Claim gesture when activating
Merge branch 'columnview-double-activation' into 'master'
mediastream: Rename an api to avoid name collisions
Merge branch 'media-stream-name-collision' into 'master'
Merge branch 'macos-input-method' into 'master'
Revert "progressbar: Avoid redundant storage"
label: Fix mnemonic handling
Add a mnemonic testcase
Merge branch 'label-underline-markup' into 'master'
Merge branch 'cherry-pick-4ba89f25' into 'master'
droptarget: Rename :drop to :current-drop
mediastream: Some more api renaming
Merge branch 'drop-target-name-collision' into 'master'
Merge branch 'media-stream-name-collision' into 'master'
Merge branch 'fix-3793' into 'master'
examples: Drop a redundant frame
examples: Use existing icons
bloatpad: Improve accel dialog
bloatpad: Give the toolbar a facelift
bloatpad: Add icons as resources
print-editor: Make accels work
actionobserver: Clarify primary_accel_changed docs
action muxer: Propagate accel changes
menutrackeritem: Be more careful with accel changes
action muxer: Propagate registrations further up
shortcutcontroller: Add a way to update accels
window: Propagate accel changes
shortcutcontroller: Don't reinject menu accels
widget-factory: Show Ctrl-? in the menu
testsuite: Avoid a compiler warning
Merge branch 'matthiasc/for-master' into 'master'
Merge branch 'wip/chergert/fix-broadway-build' into 'master'
macos: Fix a compiler warning
treeviewcolumn: Clip header buttons
Merge branch 'matthiasc/for-master' into 'master'
ci: Build Broadway on MacOS
gsk: Respect max element vertices limitation
Merge branch 'matthiasc/for-master' into 'master'
Merge branch 'gsk-big-batches' into 'master'
Merge branch 'fix-3798' into 'master'
dnd: Add another assertion
wayland: Fix some dnd corner case
docs: Tweak wording
checkbutton: Match GtkButton behavior
Merge branch 'wip/chergert/textview-access-to-contexts' into 'master'
docs: Add a section about Drag-and-Drop
docs: Fix a typo
Merge branch 'macos-input-method' into 'master'
Merge branch 'fix_tests_testdnd' into 'master'
Merge branch 'checkbutton-release-outside' into 'master'
Merge branch 'ebassi/filechooser-no-trash' into 'master'
Merge branch 'dnd-fixes' into 'master'
Merge branch 'wip/chergert/gdk-macos-gdkdrop' into 'master'
Merge branch 'wip/sadiq/reveal-controls-on-touch' into 'master'
Revert "gsk: Respect max element vertices limitation"
gsk: Don't overflow vbo_count
Merge branch 'gtklistitemfactory-autocleanup' into 'master'
Merge branch 'wip/exalm/buttons' into 'master'
Merge branch 'avoid-batch-size-overflow' into 'master'
Update hello-world.c
Merge branch 'hello-world-fixup' into 'master'
gsk: Use the right limit for batch size
gsk: Another vbo_size overflow fix
Merge branch 'more-vbo-overflow' into 'master'
wayland: Look for cursor themes in $HOME
Merge branch 'wayland-cursor-theme' into 'master'
Merge branch 'wip/chergert/fix-texthistory-grouping' into 'master'
Add another text history test
Merge branch 'text-undo-test' into 'master'
Merge branch 'wip/baedert/wat' into 'master'
popovermenu: Scroll when necessary
Add a simple python example
Merge branch 'python-example' into 'master'
mediastream: Rename apis one more time
Cosmetics
Merge branch 'scrolling-menus' into 'master'
Merge branch 'fix-gir' into 'master'
Merge branch 'matthiasc/for-master' into 'master'
filechooser: Avoid a critical
docs: Improve the gtk4-launch man page
Merge branch 'man-page-improvement' into 'master'
Merge branch 'fix-filechooser-critical' into 'master'
text: Update placeholder visibility more often
widget-factory: Add a default button
docs: Fix various link formatting
Merge branch 'placeholder-visibility' into 'master'
Merge branch 'matthiasc/for-master' into 'master'
Merge branch 'master' into 'master'
menubutton: Make menu buttons activatable again
font button: Make font buttons activatable again
colorbutton: Make color buttons activatable again
appchooserbutton: Make buttons activatable again
Add a simple Javascript example
Merge branch 'wip/remove-cloudprint' into 'master'
Merge branch 'js-example' into 'master'
gtk-demo: Add a slider to the menu example
Merge branch 'matthiasc/for-master' into 'master'
Merge branch 'wl-since' into 'master'
Merge branch 'text-cursor-extents' into 'master'
Merge branch 'wip/exalm/scroll-touch' into 'master'
Merge branch 'invisible-char-fix' into 'master'
Merge branch 'dynamic-typelib-path' into 'master'
Merge branch 'gdkkeys-m' into 'master'
Merge branch 'wip/chergert/fix-4094' into 'master'
Merge branch 'activatable-buttons' into 'master'
ngl: Make the C half-float implementation accessible
tests: Add some fp16 tests
Merge branch 'fp16-tests' into 'master'
snapshot: Handle transparent opacity nodes correctly
ngl: Do nothing for transparent color nodes
ngl: Do nothing for transparent text nodes
Merge branch 'wip/baedert/for-master' into 'master'
Merge branch 'transparent-optimizations' into 'master'
ngl: Handle negative scales
Merge branch 'wip/chergert/fix-texthistory-insert' into 'master'
testsuite: Avoid negative scales with gl renderer
Merge branch 'metainfo' into 'master'
Merge branch 'fix-negative-scales' into 'master'
Use pango from the main branch
Merge branch 'pango-main' into 'master'
reftests: Enforce default settings
Merge branch 'ci-default-settings-4' into 'master'
Merge branch 'win32.hidpi.cleanup' into 'master'
Merge branch 'tooltip-hig' into 'master'
Merge branch 'fix-dialog-docs' into 'master'
Merge branch 'wip/otte/build' into 'master'
Sync included icons from adwaita-icon-theme
Merge branch 'sync-icons' into 'master'
Merge branch 'destroy-pointer-gestures' into 'master'
Add more sysprof marks
Merge branch 'startup-profiling' into 'master'
Add more sysprof marks
Merge branch 'startup-profiling' into 'master'
stack: GtkStackPage:name is not construct-only
Cosmetics
Merge branch 'matthiasc/for-master' into 'master'
Merge branch 'stack-page-name' into 'master'
Merge branch 'wip/exalm/gtktext-selection-fix' into 'master'
ngl: Speed up clipping calculations a bit
ngl: Reduce type checking overhead
gsk: Add a private getter for container children
gsk: Add a shortcut for a common transform case
gsk: Optimize gsk_transform_to...
gridlayout: Avoid some unnecessary overhead
layoutmanager: Avoid some overhead
widget: Avoid GObject data for action muxer
widget: Avoid some unnecessary back-and-forth casting
sizerequest: Keep branches in sync
sizerequest: Simplify some code
Merge branch 'misc-speedups' into 'master'
4.3.2
Maximiliano Sandoval R (6):
appdata: Use correct SPDX license identifier
appdata: Add content_rating
appdata: Use launchable rather than id
meson: Use a valid SPDX identifier
password_entry: Header Capitalization on tooltip
gtk/builder: Port example to GTK 4
Mohammed Sadiq (1):
video: Reveal controls on tap
Patrick Griffis (1):
Remove Google Cloud Print backend This service was shut down at the start of 2021.
Piotr Drąg (1):
Update POTFILES.in
Rafael Fontenelle (2):
Update Brazilian Portuguese translation
Update Brazilian Portuguese translation
Sebastian Cherek (1):
Update gtkpopcountprivate.h: undefined macro outside msvc
Timm Bäder (3):
gtkffmediafile: Fix deprecated API usage
snapshot: Replace trivial gradients with color nodes
snapshot: Only compute start and end point if we have to
Vlad Zahorodnii (2):
gdk/wayland: Fix pointer-gestures version selection
gdk/wayland: Clean up gestures if pointer capability is withdrawn
Xavier Claessens (2):
meson: Fix generate_gir() dependencies
Meson: Only g-ir-scanner warnings fatal when buit with -Dwerror=true
Yuri Chornoivan (2):
Update Ukrainian translation
Update Ukrainian translation
Zhi (3):
fix: replace deprecated metods.
fix: make the new nsview as the first responder.
macos: fix the position of curosr of input method for macos.
hudeng (1):
gdk: fix gtk app startup with 'g_value_set_boxed: assertion G_VALUE_HOLDS_BOXED (value) failed error
message' when xsettings use 'XSETTINGS_TYPE_COLOR' type
scherek (3):
Fix illegal instruction crash on x64 CPUs without POPCNT instruction when compiled with MSVC
Replaced && with || for POPCNT checks to fix the logic.
Dropped defined() for readability
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]