[vala] Created tag 0.51.1



The signed tag '0.51.1' was created.

Tagger: Rico Tzschichholz <ricotz ubuntu com>
Date: 1613162595 +0100

    0.51.1

Changes since the last tag '0.50.1':

Arne Hoch (1):
      linux: Add missing struct in cname for Spi.IocTransfer

Chris White (2):
      gstreamer-1.0: Fix direction of GLib.Value typed parameters
      gstreamer-1.0: Fix direction of Gst.Iterator.fold() ret parameter

Christopher White (1):
      glib-2.0: Bind assert_cmp* functions

Corentin Noël (2):
      glib-2.0: Add GenericArray.find_custom() as variant of find_with_equal_func()
      codegen: Report internal error for unsupported collection type in foreach

Jeremy Philippe (3):
      codegen: More use of delegate_target_type and delegate_target_destroy_type
      codegen: Reduce get_delegate_target/get_delegate_target_destroy_notify calls
      codegen: More use of delegate_target_type and delegate_target_destroy_type (2)

Mario Daniel Ruiz Saavedra (4):
      vapi: Remove SDL 1.x bindings
      vapi: Add SDL 2.x bindings
      SDL2_ttf: Add some missing methods for the Font class
      SDL2_image: Add save functions

Ole André Vadla Ravnås (1):
      vala: Avoid critical when trying to use symbol_reference of ElementAccess

Reuben Thomas (12):
      doc/vala-gen-introspect.1: fix a typo
      glib-2.0: Add return codes to FileStream.putc/puts(), like posix
      curses: Remove initial “w” from some Window method names for consistency
      curses: Add Terminfo API set, function keycodes F(n) and minor changes
      tests: Use Automake’s parallel test driver to speed up running tests
      testrunner: A lot of simplifications
      posix: Add freopen binding, as FILE.reopen()
      posix: Add POSIX, GNU and BSD Regex APIs
      vapi: Add gnu.vapi with binding for getopt_long() and some other GNU APIs
      vapi: Add enchant-2 bindings for Enchant 2.x
      glib-2.0: Improve type of OptionEntry.flags field
      libvaladoc: Fix typos copyright year

Rico Tzschichholz (196):
      Bump version suffix to 0.52
      Don't use broken and unsupported cast expression as statement
      vala: Issue an error on void initializer for local-variable
      gtk4: Update to 3.99.2+949f22b8
      gtk4: Attribute Gsk.ShaderArgsBuilder.free_to_args with DestroysInstance
      gtk4: Update to 3.99.2+2b036744
      glib-2.0: Fix return-type of Uri.parse_params() binding
      rest-0.7: Fix ParamsIter.next() binding
      posix: Declare fstat, stat, lstat and fstatat as public
      testrunner: Add "-Werror=return-local-addr" flag
      codegen: Don't use inferred type for temp-value to access generic property
      libvaladoc: Don't filter-out generic type-parameters of delegates
      gtk4: Update to 3.99.3+25a1c421
      gstreamer: Update from 1.19.0+ git master
      vapi: Update GIR-based bindings
      gio-2.0: Fix binding of Resolver.lookup_service*()
      vala: Allow markup-reader to accept spaces around '=' of attribute assignment
      gtk4: Update to 3.99.3+8880e3bd
      alsa: Fix PcmDevice.set_poll_descriptors_revents() binding
      gtkmodule: Support "binding" to bind GtkCallback to class of given property
      codegen: Update outdated array _size_ variable of captured local-variable
      vala: CodeNode.source_reference is optional, so let the API respect that
      valadoc: Don't call CodeContext.pop() on empty stack
      curses: Correctly use [PrintfFormat] attribute
      valadoc: Refactor setup of main runtime
      vala: Convert Report.*() to real printf-like functions
      codegen: Make use of new printf-like API of Report.*()
      vala: Make use of new printf-like API of Report.*()
      libvaladoc/girimporter: Skip "docsection" elements in <namespace>
      valadoc: Correctly set verbose flag on CodeContext
      vala: Use DataType.compatible() to check for string concatenation
      tests: Actually export PKG_CONFIG_PATH and LD_LIBRARY_PATH in tests extra
      Perform runtime version check of libvala
      girwriter: Infer gir_namespace/version from target GIR filename
      gtk4: Update to 3.99.4+0d82faa2
      gstreamer: Update from 1.19.0+ git master
      vala: Avoid taking extra reference of foreach collection for index iteration
      vala: Accept "unowned var" as type for foreach variable declaration
      glib-2.0: Improve GenericArray.length property
      vala: Add support for type narrowing
      vapigen: Avoid superfluous cast
      vala: Cache async parameter lists of coroutine methods
      vala: Make sure parent_symbol for special async parameters is available
      vala: Properly restore SemanticAnalyzer.current_symbol to its original value
      codegen: Improve GValueModule.visit_cast_expression()
      codegen: Use Expression.target_type/value_type in visit_cast_expression()
      vala: Require a valid DataType instance for every TargetValue
      vala: More copying of dedicated data-type instances for code-nodes
      DEBUG
      Revert errornous git push
      codegen: Drop obsolete dedicated handling of property value-parameter
      tests: Add more "delegate" tests to increase coverage
      tests: Add string.printf() test to increase coverage
      tests: Add "constructor with inner error" test to increase coverage
      tests: Add "translated string constant" test to increase coverage
      ccode: Use __attribute__ replacements of G_GNUC_* for posix profile
      codegen: Apply CCodeModifiers.PRINTF to "string_printf" (POSIX)
      gtk4: Update to 3.99.4+7551f85d
      gstreamer: Update from 1.19.0+ git master
      gio-2.0: Update to 2.67.0+6e9ed964
      manual: Update from wiki.gnome.org
      Sync NEWS from 0.50
      glib-2.0: Add GLib.[S]List.is_empty() convenience methods for non-null
      gtk4: Use correct cheader_include for wayland/x11 gdk backend
      vala: Report an error if gio-2.0 is missing for DBus support
      gtk4: Update to 3.99.5.1+2d3a3986
      gstreamer: Update from 1.19.0+ git master
      webkit2gtk-4.0: Update to 2.30.3
      gtk4: Update to 4.0
      vala: Use common visitor schema for PointerIndirection expressions
      vala: Add missing TraverseVisitor.visit_addressof_expression()
      codewriter: Wrap AddressofExpression and PointerIndirection in parens
      vala: value_type of PointerIndirection expressions must not be owned
      gtk4: Don't rename binding for gtk_css_provider_load_from_data
      vala: Ownership transfer of inline-allocated array is not allowed
      gtk4: Update to 4.0.0+0fcf01dd
      tests: Add "array creation" tests to increase coverage
      codegen: Use CCodeInvalidExpression instead of place holders
      codegen: Drop superfluous "method_has_wrapper" helper
      codegen: Clean up handling of type parameters in generate_cparameters()
      glib-2.0: Make PtrArray a subclass of GenericArray
      codegen: Don't leak memory of already assigned out-parameter on error
      codegen: Don't leak memory on internal value comparison of property setter
      tests: Add more "array field initializer" tests to increase coverage
      tests: Add "string switch" test to increase coverage
      glib-2.0: Add new symbols from 2.68
      gobject-2.0: Add new symbols from 2.68
      gio-2.0: Update to 2.67.1+2bd86268
      gstreamer: Update from 1.19.0+ git master
      vapi: Update GIR-based bindings
      codegen: Fix assignment of casted struct value to property
      gtk4: Update to 4.0.1
      gio-2.0: Update to 2.67.2+46097e9b
      Sync NEWS from 0.50
      vala: Improve detection of duplicate package source files
      webkit2gtk-4.0: Update to 2.31.1
      girparser: Handle anonymous delegate not backed by virtual-method or signal
      girparser: Minor improvement to field getter detection
      gdk-pixbuf-2.0: Update to 2.42.3~
      Regenerate GIR-based bindings
      libvaladoc/html: Don't sort struct fields to keep their original order
      vala: GtkChild fields/properties must be declared as unowned
      vala: Don't allow assigning GtkChild fields/properties
      tests: Add more invalid "GtkTemplate" tests to increase coverage
      vala: Set this_parameter of method representing property accessor
      vala: Let method representing property accessor inherit GIR.visible attribute
      tests: Extend "girparser" test and use vapigen to parse generated gir
      girwriter: Write instance-parameter elements
      libvaladoc: Correctly retrieve value for Api.Class.is_compact
      vala: Make Class.is_compat/is_immutable/is_singleton read-only
      girparser: Discover our very own array length fields
      gtk4: Update to 4.0.2
      gstreamer: Update from 1.19.0+ git master
      vapi: Update GIR-based bindings
      valadoc: Replace png icons with elementary's svg version
      Update THANKS from git log
      vala: Improve prototype-string of CallableType
      tests: Add more "parser" tests to increase coverage
      codegen: Clean up expression casts in CCodeAssignmentModule.visit_assignment()
      vala: Apply stricter condition for lambda to delegate assignment
      codewriter: Append new-line for nested block statements
      vala: Don't prepend "unowned" in VarType and leave that to the CodeWriter
      girparser: Apply "delegate_target" metadata for methods and parameters
      gtk+-3.0,gtk4: Fix some delegate return values and parameters
      cairo: Fix a few binding errors
      cairo: Fix some ctor binding errors
      gio-2.0: Fix binding of PollableOutputStream.write*_nonblocking()
      gio-2.0,gtk+-3.0,gtk4: Drop explicit c-type attributes of va_list parameters
      gobject-2.0: Fix a few binding errors
      pango: Fix a few binding errors
      goocanvas-2.0: Fix some field types
      vala: Add CallableExpression interface for MethodCall/ObjectCreationExpression
      girparser: Apply "destroy_notify_cname" metadata for fields
      curses: Fix a few binding errors
      alsa: Fix a few binding errors
      bzlib: Fix a few binding errors
      sqlite3: Fix a few binding errors
      libgvc: Fix a few binding errors
      posix: Fix a few binding errors
      gstreamer-1.0: Fix a few binding errors
      vala: Don't allow disposable SimpleType structs
      codegen: Improve support of SimpleType struct constructors
      Add further support for params arrays in constructors
      gdk-3.0,gdk-x11-3.0,gtk+-3.0,gtk4: Fix a few binding errors
      gobject-2.0: Fix a few binding errors
      gdk-pixbuf-2.0: Fix Pixbuf.save_to_streamv_async()
      gio-2.0: Pick up missing invoker for some AppInfo/File.*() methods
      vala: NoWrapper methods must be declared abstract or virtual
      codegen: Handle NoWrapper attribute of interface methods on caller side
      codegen: Don't emit invoker for methods attributed with NoWrapper
      girwriter: Don't emit invoker for methods attributed with NoWrapper
      gtk+-2.0,javascriptcoregtk-4.0: Wrong usage of CCode.type_cname attribute
      codegen: Add CCode.type_get_function and get_ccode_type_get_function()
      girparser: Apply "type_get_function" metadata for classes and inferfaces
      codegen: Allow CCode.type_cname for classes and use get_ccode_type_name()
      codegen: Handle NoWrapper attribute of async methods on caller side
      codegen: Always use G_TYPE_INSTANCE_GET_CLASS/INTERFACE for external symbols
      fuse: Fix a few binding errors
      libxml-2.0: Fix a few binding errors
      codegen: Don't emit invoker for async methods attributed with NoWrapper
      tests/girwriter: Add tests for async methods attributed with NoWrapper
      girparser: Set CCode.type_cname for classes if it doesn't match our default
      codegen: Add get_ccode_no_wrapper() and use it
      codegen: Also check array type of variable argument for ref parameters
      vala: Rename Loop to LoopStatement and introduce a common base class
      ccode: Minor API cleaning and additions
      codegen: Use CCodeDeclaratorSuffix to emit array length of constants
      codegen: Make sure types of implicit delegate parameters are declared
      codegen: Improve handling of recursive DelegateType
      codegen: Don't leak array memory after it was implicitly copied
      codegen: Use g_boxed_free in free-wrapper for heap-allocated GLib.Value
      vala: GLib.Value unboxing returns unowned value
      vala: Don't allow GLib.Value casting to nullable struct/simple types
      codegen: Don't leak GLib.Value when implicitly unboxing it
      codegen: Use temp_ref_values list instead of patching the AST
      codegen: Don't leak memory moving heap-allocated struct to stack
      codegen: Chain up to base struct destroy function
      tests: Don't leak array if length is -1
      vala: Add Block.unreachable_exit and have it set accordingly by FlowAnalyzer
      testrunner: Add "-Werror=return-stack-address" flag
      codegen: Use g_memdup2 if target glib >= 2.68 is set
      glib-2.0: Add new symbols from 2.68
      codegen: Replace "g_memdup" with "_vala_memdup2" for target glib < 2.68
      gstreamer-1.0: Set CCode.type_id of MiniObject to G_TYPE_BOXED
      gee: Replace Memory.dup() with GLib.malloc() and Memory.copy()
      gstreamer: Update from 1.19.0+ git master
      gtk4: Update to 4.1.0+2712f536
      gio-2.0: Update to 2.67.3
      vapi: Add libunwind-generic binding
      codegen: Correctly retrieve symbol_reference of nested cast expressions
      libvaladoc: Add wrapper for "agedge" of graphviz
      build: Ease source for AC_LANG_SOURCE of CGRAPH check
      codegen: Strip all nested occurances of CCodeCastExpression
      codegen: Include <string.h> for memcpy usage in _vala_memdup2()
      sdl2: Fix a couple of binding errors and attribute issues
      Release 0.51.1

Simon Werbeck (2):
      codegen: Support chain up to simple generics constructor
      Add support for 'opaque' compact classes

Ulrich Küttler (1):
      vala: SliceExpression need to return heap-allocated or unowned references


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]