[gtk] Created tag 4.5.1
- From: Matthias Clasen <matthiasc src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gtk] Created tag 4.5.1
- Date: Fri, 17 Dec 2021 04:23:26 +0000 (UTC)
The unsigned tag '4.5.1' was created.
Tagger: Matthias Clasen <mclasen redhat com>
Date: 1639714995 -0500
4.5.1
Changes since the last tag '4.5.0':
Alexandros Theodotou (2):
fix typo in GtkDragSource doc
gesture: fix typo in docs
Anders Jonsson (1):
Update Swedish translation
Asier Sarasua Garmendia (2):
Update Basque translation
Update Basque translation
Aurimas Černius (2):
Updated Lithuanian translation
Updated Lithuanian translation
Bastien Nocera (1):
listbox: Explain behaviour of GtkListBoxCreateWidgetFunc
Benjamin Otte (91):
egl: Set the draw buffer to GL_BACK_LEFT
gl: Use GL_BACK_LEFT
gdk: #if => #ifdef
macos: Fix return value
Merge branch 'wip/otte/for-master' into 'master'
Revert "label: Never measure more than max-width-chars"
label: Redo measure() code
boxlayout: Compute opposite size properly
picture: Setting can-shrink requires a resize
Merge branch 'wip/otte/for-master' into 'master'
boxlayout: Be more careful with what to consider natural size
label: Don't deduce label width from logical rect
reftests: Add reftest for last 2 issues
Merge branch 'wip/otte/for-master' into 'master'
label: max-width-chars has no effect on smaller text
label: max-width-chars should be ignored sometimes
demos: Update for climate change and Covid
Revert "sizerequest: Only check reported baselines if requested"
boxlayout: Don't listen to comments
boxlayout: Split loop into if statmement
boxlayout: Fix broken min-size-for-opposite-size
Merge branch 'wip/otte/for-master' into 'master'
label: Handle width-chars > text width
Merge branch 'wip/otte/for-master' into 'master'
gtk-demo: Don't use deprecated librsvg API
Merge branch 'wip/otte/for-master' into 'master'
css: Don't crash when color stop offsets descend
Merge branch 'wip/otte/for-master' into 'master'
build: Don't use any -Werror in release builds
label: Don't do more work than necessary
Merge branch 'wip/otte/for-master' into 'master'
build: Actually use the extra warnings
build: Disable gcc warnings as warnings, too
label: Don't add a pixel where none should be added
Merge branch 'wip/otte/for-master' into 'master'
sizerequest: Add a critical when for_size is too small
widget: Don't forget margins when adjusting
widget: force adjustment method is one size is FILL
stack: Turn the homogenenous variables into an array
stack: Index the homogeneous array by orientation
stack: Make sure to not under-measure children
paned: Always query at least min size
sizerequest: Use g_printerr() for debug messages
sizerequestcache: Increase size
widget: Remove a check
Merge branch 'wip/otte/for-master' into 'master'
sizerequest: Change critical message
window: properly compute desired size
paned: Compute the right handle size
builder-tool: Don't simplify enums too much
Merge branch 'wip/otte/for-master' into 'master'
window: Always clamp to max size
widget: Clear size request cache on queue_resize()
window: Properly distribute size between title and child
Merge branch 'wip/otte/for-master' into 'master'
window: Add a new fancy way to compute min size
Merge branch 'wip/otte/hfw-min-size' into 'master'
testsuite: Make function arguments const
rendernode: Simplify conic gradient code
texture: Remove gdk_texture_download_float()
node-editor: Display errors
GL renderer: Remove noperspective usage
label: Don't set ellipsized size as natural size
Merge branch 'wip/otte/for-main' into 'main'
Merge branch 'gtk4-win32-egl' into 'main'
Merge branch 'check-for-unknown-duration' into 'main'
gtktypes: GTK_INVALID_LIST_POSITION should be an int
Merge branch 'wip/otte/for-main' into 'main'
viewport: Use array for member variables
viewport: Actually report the size we're gonna allocate
Merge branch 'wip/otte/viewport' into 'main'
Revert "viewport: Actually report the size we're gonna allocate"
viewport: Allocate properly
Merge branch 'wip/otte/viewport' into 'main'
reftests: Rename a bunch of tests
reftests: Add center-center reftests without GtkOverlay
Merge branch 'fix-picture-natural-size-0' into 'main'
inspector: Add a clipboard page
contentformats: Make sure 0 elements means the array is NULL
Merge branch 'wip/otte/inspector' into 'main'
x11: Keep a reference to the SelectionOutputStream while writing
x11: Explicitly close_async() the output stream
x11: Explicitly track end of stream
x11: Don't delete important signal handlers randomly
Merge branch 'wip/otte/for-main' into 'main'
label: word-char wrapping should word-wrap for natural size
label: Fix docs
label: Fix docs
inspector: Remove a stray g_print()
inspector: Add measure graph
Merge branch 'wip/otte/inspector' into 'main'
Bilal Elmoussaoui (3):
gtk: fix broken gi-docgen annotation in IconView
g-i: add missing since annotations
gdk: drop removed method from the header
Caolán McNamara (2):
update focus indicators in popovers
remove some unused declarations
Carlos Garnacho (8):
gdk/wayland: Do not use xdg_wm_base.ping serials as "user input" serials
gtkwidget: Do not check event sequence state before cancelling gesture
gtkgesture: Do not cancel gesture when setting DENIED state
gtkmain: Disable implicit grab active state on CROSSING_GRAB leave events
gdk/wayland: Use right modifiers for tablet button events
gdk/wayland: Unset GDK_BUTTON1_MASK on proximity_in
gesturestylus: Use GtkEventControllerEvent events to track changes
gtkimcontextwayland: Set a higher IO extension priority
Christian Hergert (7):
a11y: return -1 if parent is NULL
inspector: add im-module
surface: add missing va_marshaller for layout signal
menutracker: reduce allocations and signal emission
actionmuxer: avoid duplicate and recursive work
macos: fix crash in imcontextquartz
a11y: return -1 if parent is NULL
Chun-wei Fan (10):
GDK-Win32: Drop GDK_WIN32_ENABLE_EGL flag
GDK-Win32: Port to common EGL handling code
gdkdisplay.c: Fix builds without EGL
GDK-Win32: Realize EGL using common realization code
GDK-Win32: Make EGL a runtime opt-in
GDK-Win32: Fix AeroSnap indicator and positioning
GDK-Win32: Make surface ready for updates
gdksurface-win32.c: Rename window->surface as appropriate
gdksurface-win32.c: Call gdk_surface_set_egl_native_window()
gskglcompiler.c: Force GLSL version 300 es as needed
Danial Behzadi (1):
Update Persian translation
Daniel Mustieles (2):
Updated Spanish translation
Updated Spanish translation
Emmanuele Bassi (23):
docs: Fix link to g_signal_emit()
docs: Add missing annotation
build: Collect gi-docgen's common arguments
Merge branch 'build-fix' into 'master'
build: Don't use ld when cross-compiling
Merge branch 'these-are-flags' into 'master'
docs: Fix wrong fragments in type links
Merge branch 'ebassi/docs-link-fixes' into 'master'
docs: Fix typo in link
Merge branch 'ebassi/for-master' into 'master'
Unrealize ATContext on unroot
docs: Enable OpenSearch on our references
docs: Annotate Label.get_selection_bounds() out arguments
docs: Fix link in GtkSymbolicColor description
docs: Fix description for CellRendererAccelMode
docs: Add blurb for GtkEditableProperties.
Merge branch 'ebassi/docs-fixes' into 'master'
Merge branch 'gtk-init-doc-update' into 'master'
Merge branch 'ebassi/issue-4421' into 'master'
Merge branch 'fix_typo_gesture' into 'master'
Update placeholder visibility when setting a buffer
Merge branch 'gi-const' into 'main'
Add a boxed GType for GtkBitsetIter
Fabio Tomat (1):
Update Friulian translation
Fran Dieguez (2):
Update Galician translation
Update Galician translation
Fred Morcos (1):
Documentation fix and whitespace cleanup
Garrett Regier (11):
builder: Avoid double string lookup in precompile
builder: Use a string chunk for precompile
builder: Combine attribute name and value allocations
builder: Embed text length in precompile
builder: Use a reasonable default string size in precompile
builder: Use a GQueue in precompile
builder: Reduce memory usage in precompile
builder: Use a flexible array for attributes in precompile
builder: Avoid g_hash_table_get_values() in precompile
builder: Remove root special case from precompile
builder: Use g_slice_free_chain() for strings in precompile
Georg Vienna (1):
textchildanchor: allow to specify replacement character
Goran Vidović (2):
Update Croatian translation
Update Croatian translation
Hodong Kim (1):
Fix typos
Hugo Carvalho (8):
Update Portuguese translation
Update Portuguese translation
Update Portuguese translation
Update Portuguese translation
Update Portuguese translation
Update Portuguese translation
Update Portuguese translation
Update Portuguese translation
Ian Douglas Scott (4):
gdk/wayland/surface: Move `server_decoration` to `GdkWaylandToplevel`
gdk/wayland/surface: Move `*exported` to `GdkWaylandToplevel`
gdk/wayland/surface: Move `*idle_inhibitor*` to `GdkWaylandToplevel`
gdk/wayland/surface: Remove unused argument
Ivan Molodetskikh (2):
gstmediafile: Correctly report unknown duration
picture: Return natural size 0 for size 0
Jakub Kulík (1):
docs: Mention GtkImage and GtkPicture changes
Jakub Steiner (3):
styling: Have unfocused selections
Revert "styling: Have unfocused selections"
selections: have unfocused state
Jonas Ådahl (2):
Merge branch 'gdksurface-wayland' into 'master'
x11: Trap error when getting CRTC info
Jordi Mas i Hernandez (2):
Update Catalan translation
Update Catalan translation
Luca Bacci (6):
GdkWin32: Use a signed integral type for the DPI scale
GdkWin32: Remove the global screen offset
Merge branch 'forward-port-mr-3931-to-gtk4' into 'master'
Merge branch 'fix-aerosnap-4' into 'master'
Merge branch 'win32-egl-cleanup' into 'master'
Merge branch 'fix-3728-3799' into 'main'
Marc-André Lureau (1):
gtk: fix GTK_INVALID_LIST_POSITION type
Marco Melorio (2):
docs: Tag Gdk.ModifierType as flags
picture: Setting keep-aspect-ratio requires a redraw
Matthias Clasen (149):
widget-factory: Add a color button to the toolbar
Don't make all buttons in toolbars flat
theme: Remove GtkToolbar remnants
Revert "ci: Allow macos to fail"
Merge branch 'ci-require-macos' into 'master'
Merge branch 'small-check' into 'master'
testsuite: Set GDK_DEBUG unconditionally
reftest: Stop setting GDK_RENDERING
reftest: No blinking, please
listbase: Sink adjustments
Merge branch 'reftest-no-blink' into 'master'
Merge branch 'activate-signal-dropdown-combobox' into 'master'
Merge branch 'listview-sink-adjustment' into 'master'
Merge branch 'taozuhong-master-patch-22982' into 'master'
Merge branch 'ebassi/cross-bundle' into 'master'
Merge branch 'wip/carlosg/no-ping-serials-for-input' into 'master'
Merge branch 'yurchor-master-patch-77064' into 'master'
Merge branch 'wip/baedert/for-master' into 'master'
Merge branch 'remove_some_unused_declarations' into 'master'
gtk-demo: Avoid a missing icon
Remove a confusing comment
textview: Don't leave embedded children behind
Handle new pango api
css: Change the way case variants are handled
Bump the pango requirement to 1.49.3
Merge branch 'small-caps' into 'master'
Merge branch 'master' into 'master'
Merge branch 'wip/jimmac/unfocused-selections' into 'master'
flatpak: Add pango to manifest
Merge branch 'flatpak-build-fix' into 'master'
Merge branch 'wip/otte/no-errors-ever-again' into 'master'
Merge branch 'wip/carlosg/cancelled-gestures' into 'master'
Merge branch 'compose-cache-symlinks' into 'master'
Merge branch 'wip/carlosg/x11-wm-drags' into 'master'
Merge branch 'wip/otte/for-master' into 'master'
Merge branch 'bilelmoussaoui/since-annotations' into 'master'
Fix formatting error in demo about dialogs
Merge branch 'matthiasc/for-master' into 'master'
Don't spam debug messages into TAP output
Merge branch 'matthiasc/for-master' into 'master'
Merge branch 'picture-ratio-redraw' into 'master'
Merge branch 'msal4-master-patch-74685' into 'master'
node-editor: Don't make paned shrinkable
Merge branch 'matthiasc/for-master' into 'master'
Merge branch 'wip/fix-randr-race' into 'master'
Go back to using pango for glyph rendering
Merge branch 'missing-the-missing-glyphs' into 'master'
fontchooser: Avoid setting variations needlessly
Merge branch 'font-chooser-variations-fix' into 'master'
Update references to master in the repository
Mention main in NEWS and README.md
textview: Respect editability for Emoji
inspector: Make dropdowns bigger
textview: Avoid misplacing the Emoji chooser
docs: Clarify a sentence in the migration guide
Merge branch 'matthiasc/for-main' into 'main'
Merge branch 'update_focus_indicators_in_popovers' into 'main'
textbuffer: Fix pasting text
textbuffer: Try harder to fix pasting
Merge branch 'matthiasc/for-main' into 'main'
Deprecate GdkDevice:source
Add a testcase for scroll-to-mark
textview: Improve scroll-to-mark behavior
Merge branch 'wip/carlosg/tablet-fixes' into 'main'
Merge branch 'issue-4376' into 'main'
Bump pango req
Beef up the tabs demo
Merge branch 'better-tabs-demo' into 'main'
Merge branch 'text-anchor-replacement-char' into 'main'
textview: Provide more context to input methods
Merge branch 'text-scroll-test' into 'main'
Merge branch 'textview-im-surrounding' into 'main'
Merge branch 'wip/chergert/inspector-im-module' into 'main'
Merge branch 'wip/hadess/listbox-fixes' into 'main'
Merge branch 'wip/carlosg/im-wayland-module-priority' into 'main'
Merge branch 'wip/chergert/reduce-action-muxer-allocations' into 'main'
Merge branch 'wip/chergert/layout-marshaller' into 'main'
Merge branch 'wip/chergert/fix-recursive-action-muxer' into 'main'
Merge branch 'wip/chergert/fix-macos-crash' into 'main'
Merge branch 'bilelmoussaoui/header' into 'main'
Merge branch 'wip/jimmac/unfocused-selection-dejavu' into 'main'
Fix dialog-less printing
Add a missing since tag
Require meson 0.59
Fix the targets variable in pc files
ci: Use meson 0.59 on macos
ci: Use meson 0.59 for msvc
Merge branch 'missing-since-tag' into 'main'
Merge branch 'bump-meson-dep' into 'main'
Merge branch 'fix-printer-enumeration' into 'main'
Merge branch 'deprecate-device-source' into 'main'
Restore the GtkTextchild abi
Merge branch 'fix-textchild-abi' into 'main'
docs: Small improvement
gtk-demo: Rewrite the clipboard demo
Merge branch 'new-clipboard-demo' into 'main'
gtk-demo: Small followup fixes
Merge branch 'clipboard-demo-improvements' into 'main'
droptarget: Improve the docs
gtk-demo: Add dnd back to the clipboard demo
Merge branch 'clipboard-demo-improvements' into 'main'
inspector: Show more datatypes for the clipboard
gdk: Drop some pointless code
Merge branch 'clipboard-demo-improvements' into 'main'
dragicon: No events, please
dragicon: Provide default icons for more types
Merge branch 'matthiasc/for-main' into 'main'
colorswatch: Make drag source optional
dragicon: Make color icons work in X11
colorbutton: No nested drag sources, please
Merge branch 'fix-x11-drag-icons' into 'main'
Merge branch 'wip/baedert/for-master' into 'main'
buildertool: Fix a possible crash
buildertool: Be more robust
Merge branch 'builder-tool-fixes' into 'main'
builderparser: Be more robust
buildertool: Be more robust
Merge branch 'builder-tool-fixes' into 'main'
tiff loader: Catch more errors
Merge branch 'matthiasc/for-main' into 'main'
builder: Use GMarkup properly
Merge branch 'matthiasc/for-main' into 'main'
builder: Drop irrelevant whitespace in precompile
builder: Drop empty text chunks when precompiling
Merge branch 'optimize-precompile' into 'main'
Merge branch 'ebassi/issue-4543' into 'main'
inspector: Use a listview in the recorder
Merge branch 'matthiasc/for-main' into 'main'
inspector: Tweaks to the recorder
inspector: More tweaks to the recorder
inspector: Add event recording
inspector: Remove debug spew
Cosmetrics: Remove mention of a nonexisting type
inspector: Show event history in recorder
Fix event history
Merge branch 'event-recorder' into 'main'
docs: Add some information about event axes
inspector: Add axes to event details in recorder
inspector: Details about touchpad events
gdk: Prepare touchpad events for sequences
wayland: Add sequences for touchpad gestures
inspector: Highlight event sequences
Merge branch 'event-recorder' into 'main'
Merge branch 'wip/baedert/for-master' into 'main'
Merge branch 'main' into 'main'
Merge branch 'toolbar-combobox' into 'main'
NEWS: Updates
Merge branch 'wip/otte/for-main' into 'main'
4.5.1
Maximiliano Sandoval R (3):
combobox: Make combo box activatable
dropdown: Make DropDown activatable
combo_box: Use mnemonic_activate on override
Milo Casagrande (2):
Update Italian translation
Update Italian translation
Mohammed Salman (1):
Update section-text-widget.md
Naïm Favier (1):
composetable: invalidate cache based on symlink mtime too
Piotr Drąg (3):
Update POTFILES.skip
Update POTFILES.skip
Update POTFILES.in and POTFILES.skip
Quentin PAGÈS (3):
Update Occitan translation
Update Occitan translation
Update Occitan translation
Rūdolfs Mazurs (1):
Update Latvian translation
Samuel Thibault (2):
Merge branch 'wip/chergert/fix-a11y-critical' into 'master'
Revert "a11y: return -1 if parent is NULL"
Sveinn í Felli (2):
Update Icelandic translation
Update Icelandic translation
TAO ZUHONG (2):
Make dialog content_area box as vertical, keep compatibility with GTK3
Update gtk/ui/gtkdialog.ui
Timm Bäder (7):
Merge branch 'bilelmoussaoui/gi-docgen' into 'master'
Merge branch 'fix_typo' into 'master'
paned: Don't pass values < -1 to gtk_widget_measure()
gl: Linear gradients don't support 3d transforms
settings test: Print expected and seen values
textlayout: Remove unused-but-set variables
gskglcommandqueue: Mark some variables G_GNUC_UNUSED
Tobias Bernard (1):
icon: revert object-symbolic check to be smaller
Yaron Shahrabani (2):
Update Hebrew translation
Update Hebrew translation
Yuri Chornoivan (8):
Update Ukrainian translation
Fix minor typo: Unsupportd -> Unsupported
Update Ukrainian translation
Update Ukrainian translation
Update Ukrainian translation
Update Ukrainian translation
Update Ukrainian translation
Update Ukrainian translation
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]