[vala] Created tag 0.53.1



The signed tag '0.53.1' was created.

Tagger: Rico Tzschichholz <ricotz ubuntu com>
Date: 1629461955 +0200

    0.53.1

Changes since the last tag '0.52.2':

Alistair Thomas (1):
      doc: Update man page to include more information on profiles

Corentin Noël (1):
      vala: Add foreach statement support for GLib.GenericArray

Dr. Michael Lauer (3):
      linux: Add SocketCAN bindings, and ISOTP constants and options
      linux: Substitute linux/if.h with net/if.h
      linux: Fix i2c-dev constants

Jeremy Philippe (1):
      vala: Add support for null-safe access operator

Michael James Gratton (1):
      javascriptcoregtk-4.0: Fix JSC.Class.add_property() binding

Ole André Vadla Ravnås (4):
      codegen: Skip GDBus reply handling when async callback is NULL
      gio-2.0: Improve DatagramBased.create_source() binding
      codegen: Fix support for public fields on GLib.Source subclasses
      gobject-2.0: Fix the Closure.invoke() signature

Princeton Ferro (7):
      ccode: Allow appending `#elif`, `#else` cases to CCodeIfSection
      codegen: Introduce VALA_EXPORT for public symbols to improve portability
      glib-2.0: expected_type and return value of VariantDict.lookup_value() is nullable
      glib-2.0: Add Uri.to_string/to_string_partial() (since 2.66)
      vala: this_parameter property for subroutines is nullable
      girwriter: Add explicit writable attribute to all field elements
      girwriter: Improve struct creation method binding

Rico Tzschichholz (105):
      Bump version suffix to 0.54
      vala: Add Profile.LIBC as synonym for POSIX and accept "libc" profile
      vala: Improve semantic check of simple type structs
      vala: Refactor UnresolvedSymbol/Type constructors
      parser: Minor semantic checks to improve error messages
      parser: Allow empty member-initializer and accept trailing comma
      vapi: Remove webkit-1.0 bindings
      vapi: Remove gedit-2.20 bindings
      codegen: Use ArrayType.length_type in type specific wrappers
      codegen: Use ssize_t for length variables in common array helper functions
      parser: Include INTERR token in source_reference of parsed types
      vala: length-type of arrays must not be nullable
      vapi: Update GIR-based bindings
      Support explicit nullable var-type declarations
      codegen: Make sure to include <sys/types.h> for ssize_t (POSIX)
      vala: Properly check GLib.Object naming convention for properties
      codegen: Apply gconstpointer to gpointer cast to GenericType only
      codegen: Fix access to captured generics in async method of interfaces (2)
      codegen: Add get_generic_type_expression() and handle GenericType earlier
      Make TypeParameter a TypeSymbol to resolve functions with attributes
      codegen: Unify handling of GenericType arguments/parameters
      codegen: Use if-clause for is_in_destructor() condition to be more clear
      codegen: More use of get_variable_cexpression()
      tests: Extend "finally block execution" test to increase coverage
      tests: Add "generics reference transfer" test to increase coverage
      tests: Add more "DBus" tests to increase coverage
      codegen: Emit external creation methods in bindings
      glib-2.0: Wrap TimeZone.identifier() constuctor for proper error support
      vala: length-type of arrays must not be nullable (2)
      codegen: Add missing "_return" label and "_inner_error*_" declaration in dtors
      vala: Report a warning for unhandled errors in destructors
      codegen: Don't use G_GNUC_INTERNAL on implicit type specific fields
      tests: Add "delete" test to increase coverage
      tests: Add "generic array" test to increase coverage
      tests: Extend "array field intializer" test to increase coverage
      tests: Add "properties in structs" test to increase coverage
      Sync NEWS from 0.52
      codegen: GArray, GByteArray and GPtrArray are reference counted
      tests: Add "ThreadPool" test to increase coverage
      tests: Refactor "fields" test to increase coverage
      codegen: Drop unreachable code handling (Un)LockStatements
      codegen: Replace wrongly hard coded usage of G_OBJECT_GET_CLASS
      codegen: Add CCodeBaseModule.get_this_class_cexpression() and use where possible
      codgen: Generalize CCodeBaseModule.get_this_interface_cexpression()
      codegen: Always use G_TYPE_INSTANCE_GET_CLASS/INTERFACE for external symbols (2)
      codegen: More use of get_this_{class|interface}_cexpression()
      build: Add "test-asan" make target for convenience
      vapi: Update GIR-based bindings
      gstreamer-rtp-1.0: Fix typo in re-parenting for RTCP symbols
      gstreamer-rtp-1.0: Fix some bindings errors
      gstreamer-rtp-1.0: Move some static functions to matching parent symbols
      Add support for variadic delegates
      codegen: Don't add errornous cast for unknown type_symbol
      codegen: Mark entry point method implementation "_vala_main" as static
      tests: Add "no-reply" DBus test to increase coverage
      build: Add --enable-test-ubsan configure option and "test-ubsan" make target
      ccode: Allow to add defines in a special section
      codegen/vala: Improve check for GLib.Source derived classes
      codegen: Factor out compact_class_has_instance_struct_member()
      vala: Parameter following params-array parameter is not allowed
      gstreamer: Update from 1.19.0+ git master
      webkit2gtk-4.0: Update to 2.33.1
      pango: Mark language parameter of AttrIterator.get_font() as out
      gtk4: Update to 4.3.0+24f0ae1d
      gtk+-3.0: Update to 3.24.29+f9fe28ce
      glib-2.0: Add missing has_typedef attributes on SourceFuncs delegates
      Sync NEWS from 0.52
      codegen: Allow null to initialize non-null struct inside initializer list
      codegen: Implementing GLib.Source.prepare/check is optional since 2.36
      codegen: Fix variadic constructors for compact classes and structs
      ccode: Avoid trailing space after #else of CCodeIfSection
      girwriter: Use "optional" and "nullable" instead of deprecated "allow-none"
      build: Use jing to verify generated GIR file, if available
      tests/girwriter: Add missing [Flags] annotation
      girwriter: Respect GIR.name for constants, errordomains and delegates
      testrunner: Add support for girwriter tests
      Recognize multiple valid CCode.gir_namespace/_version attributes in VAPI files
      linux: Fix some bindings errors
      gstreamer: Update from 1.19.0+ git master
      webkit2gtk-4.0: Update to 2.33.2
      gtk4: Update to 4.3.1+6818eee8
      vapi: Update GIR-based bindings
      gio-2.0,glib-2.0: Add new symbols from 2.69.0
      codegen: Use detroy_value() for delete statement
      codegen: Fix params-array in constructor for struct
      testrunner: Allow checking generated C sources
      tests: Add expected generated C sources
      vala: Rely on DataType.to_qualified_string() implementation for error-types
      tests: Don't check generated C for conditional glib test
      girparser: Never skip "function" elements
      girparser: Add "move-to" value of functions as Version.replacement
      girparser: Improve instance method detection
      Regenerate GIR-based bindings for improved instance method detection
      girwriter: Fix position of "result" parameter for struct constructor
      girparser: Add support for "final" class attribute
      Add support for sealed classes
      Slightly improve source_reference for get_dup_func_expression()
      girwriter: Write missing c:type attribute of compact class record
      gtk4: Update to 4.3.2+04f3c805
      gstreamer: Update from 1.19.0+ git master
      vapi: Update GIR-based bindings
      Sync NEWS from 0.52
      tests: Add more "null-safe access" tests to increase coverage
      webkit2gtk-4.0: Update to 2.33.3
      Release 0.53.1

satmandu (1):
      docs: Update bootstrap instructions in README.md

wxx (1):
      vala: Disallow resize() for constant arrays


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]