[librsvg] (38 commits) ...Merge branch 'viewport-offsets'



Summary of changes:

  a89f6c3... Rename argument
  dbaed8f... Combine DrawingCtx::new and draw_from_stack into a single d
  42a3edc... Create the drawsub_stack in draw_tree(), not in DrawingCtx:
  bfbbd60... Create the drawsub_stack outside the DrawingCtx
  3342df5... draw_tree - Take a single DrawingMode enum instead of limit
  e3126cb... Handle::get_node_geometry_with_viewport - inline in its two
  9065534... Remove superfluous conversion
  639c181... Svg.get_size - Inline get_unnormalized_size into here, so w
  d5e85a9... Move Svg::get_size, a relic of the C API, to handle::get_sv
  cfd0127... WIP: Add a failing test for obtaining geometries with an of
  0003ccb... WIP: disable that failing test
  70c248f... Don't special-case measuring in DrawingCtx::new
  1c7f1aa... Docs on ViewBox to remind me that it is a new coordinate sp
  cc7a54c... Make ViewBox opaque; impl Deref<Target = Rect> for it
  d1d1ce4... cargo fmt
  ce851cd... Don't clone a cr
  eec5c6d... Use a helper function to clip to a rectangle
  f1a7cc2... Store a complete ViewBox in ViewParams, not just the size
  19c426a... Define a Viewport structure and use it for the DrawingCtx.i
  5524325... Extract function to get the top viewbox
  3df8259... Always grow the stack in push_new_viewport()
  fc98fdd... Make a call to push_view_box(1.0, 1.0) consistent with the 
  1761289... Make another call to push_view_box(1.0, 1.0) consistent
  04d08ec... Add helper DrawingCtx.push_coord_units()
  077e8fa... Rename view_box_stack to viewport_stack; store full Viewpor
  ce8a2ff... New helper function to push a full Viewport
  331244b... Note that push_new_viewport() also sets a clip rectangle
  3507d6b... push_coord_units: Always push a Viewport, instead of someti
  45649c4... Give a better name to the failing test and adjust it
  f623f45... render_layer: make consistent with get_geometry_for_layer
  1ff0f6c... Really make the initial viewport have its upper-left corner
  1e2b486... (#554): Do not ignore the viewport in the geometry_for_laye
  118c3af... Add test with a viewBox
  90a1411... Add test with no width/height
  c647ba1... Add test with no intrinsic dimensions
  7b83a20... Add test with a percentage viewport
  a013c33... Move the render_to_viewport tests to intrinsic_dimensions.r
  e77ed32... Merge branch 'viewport-offsets'


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]