[mutter/gbsneto/graphene-ray: 32/40] clutter/actor: Remove '_paint' suffix from clutter_actor_should_pick_paint
- From: Georges Basile Stavracas Neto <gbsneto src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [mutter/gbsneto/graphene-ray: 32/40] clutter/actor: Remove '_paint' suffix from clutter_actor_should_pick_paint
- Date: Tue, 20 Oct 2020 19:33:30 +0000 (UTC)
commit 076d2118810a501c57ce4dbb12e42b6ad9c6e3fd
Author: Georges Basile Stavracas Neto <georges stavracas gmail com>
Date: Fri Oct 16 10:06:39 2020 -0300
clutter/actor: Remove '_paint' suffix from clutter_actor_should_pick_paint
We're not using paint to pick anymore.
https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/1509
clutter/clutter/clutter-actor.c | 13 ++++++-------
clutter/clutter/clutter-actor.h | 2 +-
src/compositor/meta-surface-actor.c | 2 +-
3 files changed, 8 insertions(+), 9 deletions(-)
---
diff --git a/clutter/clutter/clutter-actor.c b/clutter/clutter/clutter-actor.c
index 245bbd1d38..1f58ff8263 100644
--- a/clutter/clutter/clutter-actor.c
+++ b/clutter/clutter/clutter-actor.c
@@ -2323,7 +2323,7 @@ static void
clutter_actor_real_pick (ClutterActor *self,
ClutterPickContext *pick_context)
{
- if (clutter_actor_should_pick_paint (self, pick_context))
+ if (clutter_actor_should_pick (self, pick_context))
{
ClutterActorBox box = {
.x1 = 0,
@@ -2354,21 +2354,20 @@ clutter_actor_real_pick (ClutterActor *self,
}
/**
- * clutter_actor_should_pick_paint:
+ * clutter_actor_should_pick:
* @self: A #ClutterActor
*
* Should be called inside the implementation of the
* #ClutterActor::pick virtual function in order to check whether
- * the actor should paint itself in pick mode or not.
+ * the actor should pick itself or not.
*
* This function should never be called directly by applications.
*
- * Return value: %TRUE if the actor should paint its silhouette,
- * %FALSE otherwise
+ * Return value: %TRUE if the actor should pick itself, %FALSE otherwise
*/
gboolean
-clutter_actor_should_pick_paint (ClutterActor *self,
- ClutterPickContext *pick_context)
+clutter_actor_should_pick (ClutterActor *self,
+ ClutterPickContext *pick_context)
{
g_return_val_if_fail (CLUTTER_IS_ACTOR (self), FALSE);
diff --git a/clutter/clutter/clutter-actor.h b/clutter/clutter/clutter-actor.h
index 8bb7bd1745..bc858fb5a7 100644
--- a/clutter/clutter/clutter-actor.h
+++ b/clutter/clutter/clutter-actor.h
@@ -591,7 +591,7 @@ void clutter_actor_set_offscreen_redirect
CLUTTER_EXPORT
ClutterOffscreenRedirect clutter_actor_get_offscreen_redirect (ClutterActor
*self);
CLUTTER_EXPORT
-gboolean clutter_actor_should_pick_paint (ClutterActor
*self,
+gboolean clutter_actor_should_pick (ClutterActor
*self,
ClutterPickContext
*pick_context);
CLUTTER_EXPORT
gboolean clutter_actor_is_in_clone_paint (ClutterActor
*self);
diff --git a/src/compositor/meta-surface-actor.c b/src/compositor/meta-surface-actor.c
index 89cd7b0146..97202b8eb4 100644
--- a/src/compositor/meta-surface-actor.c
+++ b/src/compositor/meta-surface-actor.c
@@ -184,7 +184,7 @@ meta_surface_actor_pick (ClutterActor *actor,
ClutterActorIter iter;
ClutterActor *child;
- if (!clutter_actor_should_pick_paint (actor, pick_context))
+ if (!clutter_actor_should_pick (actor, pick_context))
return;
/* If there is no region then use the regular pick */
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]