[librsvg] Created tag 2.50.1



The signed tag '2.50.1' was created.

Tagger: Federico Mena Quintero <federico gnome org>
Date: 1601666676 -0500

    Tag for version 2.50.1

Changes since the last tag '2.50.0':

Federico Mena Quintero (53):
      Split FilterValueList tests between valid and invalid syntax
      Detect empty strings as invalid in FilterValueList::parse
      Add the string_cache crate
      Rename PropertyBag (property_bag.rs) to Attributes (attributes.rs)
      In Attributes, store the values long-term as interned atoms
      NodeData.new_element - consume the Attributes, all the way up and down
      Store the Attributes in ElementInner
      Add Element.get_attributes()
      Get rid of clone() for the initial attributes
      Simplify two functions that deal with attributes
      Get rid of the RefCell
      (#483): Support attribute matching selectors
      (#623): Remove obsolete variables from pkg-config files
      (#624): Remove obsolete librsvg-uninstalled.pc.in
      Rename argument
      Combine DrawingCtx::new and draw_from_stack into a single draw_tree function
      Create the drawsub_stack in draw_tree(), not in DrawingCtx::new
      Create the drawsub_stack outside the DrawingCtx
      draw_tree - Take a single DrawingMode enum instead of limit_to_stack/node/cascaded arguments
      Handle::get_node_geometry_with_viewport - inline in its two callers
      Remove superfluous conversion
      Svg.get_size - Inline get_unnormalized_size into here, so we can extract this function
      Move Svg::get_size, a relic of the C API, to handle::get_svg_size
      WIP: Add a failing test for obtaining geometries with an offsetted viewport
      WIP: disable that failing test
      Don't special-case measuring in DrawingCtx::new
      Docs on ViewBox to remind me that it is a new coordinate space
      Make ViewBox opaque; impl Deref<Target = Rect> for it
      cargo fmt
      Don't clone a cr
      Use a helper function to clip to a rectangle
      Store a complete ViewBox in ViewParams, not just the size
      Define a Viewport structure and use it for the DrawingCtx.initial_viewport
      Extract function to get the top viewbox
      Always grow the stack in push_new_viewport()
      Make a call to push_view_box(1.0, 1.0) consistent with the others
      Make another call to push_view_box(1.0, 1.0) consistent
      Add helper DrawingCtx.push_coord_units()
      Rename view_box_stack to viewport_stack; store full Viewport structs
      New helper function to push a full Viewport
      Note that push_new_viewport() also sets a clip rectangle
      push_coord_units: Always push a Viewport, instead of sometimes returning a copy of the last one
      Give a better name to the failing test and adjust it
      render_layer: make consistent with get_geometry_for_layer
      Really make the initial viewport have its upper-left corner at (0, 0)
      (#554): Do not ignore the viewport in the geometry_for_layer() APIs
      Add test with a viewBox
      Add test with no width/height
      Add test with no intrinsic dimensions
      Add test with a percentage viewport
      Move the render_to_viewport tests to intrinsic_dimensions.rs
      Update NEWS
      Bump version to 2.50.1

John Ledbetter (3):
      Accept multiple URI values for filter: property
      Prevent storing IRI::None in a FilterValueList
      Filter property: refactor to Filter::None and Filter::List(_)

Lars Schmertmann (1):
      css: Only allow css imports from the same base directory

Sven Neumann (10):
      Introduce helper object to clean up path handling
      Hide implementation details of FilterValueList
      Port the remaining C convenience functions to Rust
      Port obsolete C stub functions to Rust
      Make use of sudo optional in the gitlab CI rules
      Remove debian_i386:testing cross_distro test
      Allow to configure the test tolerance
      Do not allow builds to fail
      Update .gitignore
      Remove references to files that have long been removed


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]