[libmanette] Created tag 0.2.6



The unsigned tag '0.2.6' was created.

Tagger: Adrien Plazas <kekun plazas laposte net>
Date: 1606587110 +0100

    Version 0.2.6

Changes since the last tag '0.2.5':

Adrien Plazas (53):
      Add HACKING.md
      meson: Replace join_paths() by /
      meson: Update the option definition style
      meson: Add the demo option
      meson: Add the build-tests option
      meson: Move the API version and module name to the root
      meson: Add the install-tests option
      meson: Print a build summary
      Drop colons after (skip) annotations
      event: Fix %self to @self
      event: Document the event type count value
      Add a barebone documentation
      Update the GitLab repo URLs
      ci: Drop the unused deploy stage
      ci: Move the check-api-visibility task to the pre stage
      ci: Rename the test stage into build
      ci: Rename the check-api-visibility task into lint
      ci: Add the dependencies task
      ci: Rename the fedora task to unit-tests
      ci: Base the unit-tests on Flatpak
      ci: Drop the flatpak task
      ci: Drop the unused BUNDLE variable
      ci: Drop useless quotes
      ci: Build and publish the reference manual
      hacking: Document the coding style
      hacking: Document the documentation style
      ci: Drop the pages task
      readme: Make the description match the website
      doap: Make the description match the website
      doap: Update the homepage URL
      doc: Link to the online version
      doc: Describe the library in the Overview chapter
      doc: Use the package_name variable where relevant
      device: Document *_has_rumble() and *_rumble()
      device: Add a missing precondition check to *_rumble()
      device: Simplify *_set_mapping()
      device: Fix the documentation of *_get_vendor_id()
      mapping-manager: Store the full mapping string
      mapping: Don't parse the first two fields as bindings
      mapping: Better check the mapping string
      mapping: Use g_auto(GStrv) where possible
      mapping: Make some error messages more explicit
      mapping: Simplify the *_try_free funcs
      mapping: Fix a typo
      mapping: Use multiline comments
      gamecontrolerdb: Drop platform:Linux
      update-gamecontrollerdb: Drop platform:Linux,
      ci: Add the gudev task
      Use g_autoptr where possible
      Use g_clear_(pointer|object) where possible
      mapping: Use debug rather than critical for parsing errors
      Use #pragma once
      Version 0.2.6

vanadiae (35):
      doc: Adapt main page with libmanette's informations instead of retro-gtk
      doc: Remove commented-out private API documentation
      doc: Import README as main page introduction
      Fix license headers
      flatpak: Update libevdev's git repo URL
      monitor: Document *_new()
      monitor: Improve the *_iterate() documentation
      device: Document rumble functions has_rumble() and rumble()
      device: Document *_set_mapping()
      event: Improve the documentation of *_get_time()
      device: Explain where to find bustype IDs
      device: Document where to find some vendor/product IDs
      meson: Bump meson minimum version requirement
      meson: Use built-in summary functionality
      demos: Switch to meson for evdev dependency
      monitor: Give better name to signals functions
      mapping-manager: Give better name to signals functions
      demo: Give correct names to callbacks
      mapping-manager: Prefix finalize()
      monitor: Prefix finalize()
      monitor: Fix udev_client_uevent_cb()
      device: Avoid using gpointer for user_data but use directly the good type
      Use g_auto(ptr|_free) instead of manual memory management
      Use assertions instead of g_return*_if_fail in static functions
      event: Shorten *_new() function
      mapping-manager: Explain the key-value for the GUID hash-tables
      device: Remove unused force_feedback_id struct member
      device: Throw the full file error code in *_new()
      mapping-manager: Use more appropriate printing for non-programmer errors
      device: Don't throw NXIO file error in *_new() if not a gamepad
      mapping-manager: Drop the key and value variables
      device: Use printf instead of manually building the GUID
      monitor: Remove preliminary property check
      mapping-manager: Fix checking mapping file deletion
      device: Simplify inputs initialization


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]