[librsvg] Created tag 2.48.5



The signed tag '2.48.5' was created.

Tagger: Federico Mena Quintero <federico gnome org>
Date: 1590785166 -0500

    Tag for version 2.48.5

Changes since the last tag '2.48.4':

Abraham Toriz (2):
      set example's dependencies to match project's ones
      restore two notes

Bastien Orivel (1):
      (#577): Parse multiple fonts in font-family

Federico Mena Quintero (54):
      Move rsvg_g_warning and rsvg_g_critical to messages.rs
      Implement rsvg_return_if_fail / rsvg_return_val_if_fail in Rust
      Minor fix to the documentation of rsvg_pixbuf_from_file_at_size
      Do all simple argument checks in Rust
      Do all the GType checks for the C API in the Rust code
      Use a single rsvg_rust_handle_set_dpi_x_y
      Remove unused functions
      Svg::get_size - Don't convert the size to ints
      rsvg_rust_handle_get_dimensions: log errors just like in get_dimensions_sub
      Combine the get_dimensions and get_dimensions_sub implementations into a single function
      rsvg_rust_handle_get_dimensions - use get_dimensions_sub internally
      Fix internal call to get_dimensions_sub
      Move the implementation of render_cairo_sub to c_api
      Remove superfluous casts
      pixbuf_utils: don't call get_dimensions_sub twice.
      rsvg_internals: export the Rect type along with IRect
      pixbuf_utils: get rid of RsvgDimensionData as early as possible
      pixbuf_utils: Use get_geometry_sub instead of get_dimensions_sub
      Move the implementation of get_dimensions_sub to c_api
      Move the implementation of get_position_sub to c_api
      Use the cast crate for checked casts from f64 to i32
      pixbuf_utils: Maintain the original document size as f64
      pixbuf_utils: Use f64 everywhere except at the very end, and check the f64 to i32 conversion
      Test that files with big viewBox don't overflow the dimensions API
      Test that the pixbuf API doesn't overflow
      Bump version to 2.48.5
      BoundingBox: new functions rect_is_empty / ink_rect_is_empty
      generate_cairo_mask: Don't push the mask_cr for longer than needed
      generate_cairo_mask - Create the bounding box transform as per the rest of the code
      Rename Transform::new to new_unchecked
      DrawingCtx::clip_to_node - Prepare for switching to BoundingBox::rect_to_transform
      clip_to_node - Use a new function BoundingBox.rect_to_transform
      gradient: use bbox.rect_to_transform instead of checking the rect by hand
      (#593): Don't panic with an empty objectBoundingBox for a mask
      Update NEWS
      Move RsvgDimensionData to c_api
      Move RsvgPositionData to c_api
      (#596): Fix introspection data for rsvg_handle_set_stylesheet()
      Move the size_callback machinery to c_api
      Reminder to keep cairo-rs versions in sync
      Add a couple of serif fonts for the test suite
      Add test files for #577 - ensure font-family works with multiple families
      Ensure that font-family="quoted  with  multiple  spaces'" preserves the spaces
      Update NEWS
      Update criterion to 0.3 and the benchmarks to Rust 2018
      Add a benchmark for pixbuf_from_surface
      Use the rgb crate and define a CairoARGB pixel type
      Implement a Rows iterator for SharedImageSurface, yields &[CairoARGB]
      Use the rows iterator in pixbuf_from_surface to iterate the SharedImageSurface
      Reimplement pixbuf_from_surface() in terms of iterators and .as_pixels()
      Reimplement ExclusiveImageSurface::from_pixbuf() in terms of iterators
      RowsMut: keep a cairo::ImageSurfaceData around so it will mark the surface as dirty when dropped
      Update NEWS
      Fix Makefile.am for "make distcheck"


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]