[libhandy] (20 commits) ...carousel: Support add/remove animations for indicators



Summary of changes:

  e60a39e... swipeable: Add gesture state getters (*)
  c9c012b... swipe-tracker: Lazily access swipeable state (*)
  993cbf0... swipe-tracker: Remove hdy_swipe_tracker_confirm_swipe() (*)
  df35598... swipe-tracker: Add hdy_swipe_tracker_shift_position() (*)
  20d10fc... carousel-box: Rename child to widget in insert() and reorde (*)
  ba4caff... carousel-box: Implement add() through insert() (*)
  47322a8... carousel-box: Add swipe state accessors (*)
  55ec7ba... carousel-box: Add hdy_carousel_box_get_page_at_position() (*)
  b77daa6... carousel-box: Add hdy_carousel_box_get_current_page_index() (*)
  2a0a1a3... carousel-box: Shift position after page changes (*)
  ffe42d8... carousel-box: Remove hdy_carousel_box_animate() (*)
  708a697... carousel-box: Allow children to have different sizes (*)
  19e8952... carousel-box: Decouple tick callback id from the animation (*)
  0a53848... carousel-box: Extract animation struct (*)
  bf14cfe... carousel-box: Use for loop in forall() (*)
  12cc4c2... carousel-box: Add reveal-duration property (*)
  f1ba6d7... carousel-box: Animate child addition and deletion (*)
  25fa1ff... carousel: Add reveal-duration property (*)
  e019d18... carousel-box: Track child additions and removals (*)
  5ee76fb... carousel: Support add/remove animations for indicators (*)

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]