[libhandy] (41 commits) Non-fast-forward update to branch wip/exalm/paginator-animate



The branch 'wip/exalm/paginator-animate' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  bf9f228... swipeable: Add gesture state getters
  33e6592... swipe-tracker: Lazily access swipeable state
  a07f389... swipe-tracker: Remove hdy_swipe_tracker_confirm_swipe()
  db577c1... swipe-tracker: Add hdy_swipe_tracker_shift_position()
  65f0694... carousel-box: Rename child to widget in insert() and reorde
  63bcfbe... carousel-box: Implement add() through insert()
  b0627a6... carousel-box: Add swipe state accessors
  0ee893e... carousel-box: Add hdy_carousel_box_get_page_at_position()
  d68cc8c... carousel-box: Add hdy_carousel_box_get_current_page_index()
  944b729... carousel-box: Shift position after page changes
  1160ab5... carousel-box: Remove hdy_carousel_box_animate()
  fb10ee7... carousel-box: Allow children to have different sizes
  1fd88f5... carousel-box: Decouple tick callback id from the animation
  92ae139... carousel-box: Extract animation struct
  46d8f3d... carousel-box: Use for loop in forall()
  c1a9074... carousel-box: Add reveal-duration property
  9f71d6e... carousel-box: Animate child addition and deletion
  3738a1a... carousel: Add reveal-duration property
  cef3a29... carousel-box: Track child additions and removals
  25d7e0d... carousel: Support add/remove animations for indicators

Commits added to the branch:

  2bfaeb2... ci: Export the reference manual to GitLab pages (*)
  0e2770b... build: Add an override for pygobject (*)
  02bc7f8... expander-row: Move switch to the left of the arrow (*)
  49c7854... expander-row: Allow adding arbitrary action widgets (*)
  0db328d... example: Add examples of expander rows with actions (*)
  e6f821f... carousel: Set allow-mouse-drag=true by default (*)
  c0a5be4... doc: Make parallel-installatable with libhandy 0.x (*)
  d5dea97... keypad: Fix the code style (*)
  29af376... keypad: Don't force the keypad to be visible (*)
  e4731d4... keypad: Don't override its own props in the template (*)
  e390d10... keypad: Make it inherit from GtkBin (*)
  6c6425a... keypad: Add spacing properties (*)
  43fd89c... header-bar: Add .titlebar style class by default (*)
  31fc550... Update repo links (*)
  895ecec... header-bar: Account for box-shadow when clipping (*)
  b894cf2... avatar: Account for box-shadow when clipping (*)
  06a1f76... title-bar: Account for box-shadow when clipping (*)
  aba99d0... title-bar: Respect CSS min-width and min-height (*)
  cd296fa... header-bar: Respect CSS min-width and min-height (*)
  15eee53... view-switcher-title: Null-check view switcher in dispose() (*)
  a9b3ca9... view-switcher-title: Set no-show-all=true on the squeezer (*)
  e60a39e... swipeable: Add gesture state getters
  c9c012b... swipe-tracker: Lazily access swipeable state
  993cbf0... swipe-tracker: Remove hdy_swipe_tracker_confirm_swipe()
  df35598... swipe-tracker: Add hdy_swipe_tracker_shift_position()
  20d10fc... carousel-box: Rename child to widget in insert() and reorde
  ba4caff... carousel-box: Implement add() through insert()
  47322a8... carousel-box: Add swipe state accessors
  55ec7ba... carousel-box: Add hdy_carousel_box_get_page_at_position()
  b77daa6... carousel-box: Add hdy_carousel_box_get_current_page_index()
  2a0a1a3... carousel-box: Shift position after page changes
  ffe42d8... carousel-box: Remove hdy_carousel_box_animate()
  708a697... carousel-box: Allow children to have different sizes
  19e8952... carousel-box: Decouple tick callback id from the animation
  0a53848... carousel-box: Extract animation struct
  bf14cfe... carousel-box: Use for loop in forall()
  12cc4c2... carousel-box: Add reveal-duration property
  f1ba6d7... carousel-box: Animate child addition and deletion
  25fa1ff... carousel: Add reveal-duration property
  e019d18... carousel-box: Track child additions and removals
  5ee76fb... carousel: Support add/remove animations for indicators

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]